summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-18 17:11:43 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-18 17:11:43 +0000
commit6315ed708872c0e0738c66123cb8eed618cb67e0 (patch)
tree8d37d90425d363444183c2fef1f7d441fabeaa64 /x11-misc/tabbed
parentwhitespace (diff)
downloadgentoo-2-6315ed708872c0e0738c66123cb8eed618cb67e0.tar.gz
gentoo-2-6315ed708872c0e0738c66123cb8eed618cb67e0.tar.bz2
gentoo-2-6315ed708872c0e0738c66123cb8eed618cb67e0.zip
Version bump.
(Portage version: 2.2.0_alpha119/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/tabbed')
-rw-r--r--x11-misc/tabbed/ChangeLog9
-rw-r--r--x11-misc/tabbed/tabbed-0.4.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/x11-misc/tabbed/ChangeLog b/x11-misc/tabbed/ChangeLog
index 8c4d8ec3da9d..21b4e88afe59 100644
--- a/x11-misc/tabbed/ChangeLog
+++ b/x11-misc/tabbed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/tabbed
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/ChangeLog,v 1.1 2011/04/20 14:23:46 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/ChangeLog,v 1.2 2012/07/18 17:11:43 jer Exp $
+
+*tabbed-0.4 (18 Jul 2012)
+
+ 18 Jul 2012; Jeroen Roovers <jer@gentoo.org> +tabbed-0.4.ebuild:
+ Version bump.
*tabbed-0.3 (20 Apr 2011)
diff --git a/x11-misc/tabbed/tabbed-0.4.ebuild b/x11-misc/tabbed/tabbed-0.4.ebuild
new file mode 100644
index 000000000000..c2b53a42fe22
--- /dev/null
+++ b/x11-misc/tabbed/tabbed-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/tabbed-0.4.ebuild,v 1.1 2012/07/18 17:11:43 jer Exp $
+
+EAPI="3"
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple generic tabbed fronted to xembed aware applications"
+HOMEPAGE="http://tools.suckless.org/tabbed"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ x11-proto/xproto
+ ${RDEPEND}
+"
+
+src_prepare() {
+ sed \
+ -e 's|/usr/local|/usr|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
+ -e 's|^LIBS.*|LIBS = -lX11|g' \
+ -e '/^CC/d' \
+ -i config.mk || die
+ sed \
+ -e 's|{|(|g;s|}|)|g' \
+ -i Makefile config.mk || die
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake compile failed"
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ save_config config.h
+}