summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-11-02 16:24:15 +0000
committerJeroen Roovers <jer@gentoo.org>2013-11-02 16:24:15 +0000
commitb04a052619f6ba1360d31836132188525ad3e298 (patch)
tree9ee6ed6aaaacf0943f427e1afc1f3678afa758f8 /x11-misc/synergy
parentAdd missing changelog entry (diff)
downloadgentoo-2-b04a052619f6ba1360d31836132188525ad3e298.tar.gz
gentoo-2-b04a052619f6ba1360d31836132188525ad3e298.tar.bz2
gentoo-2-b04a052619f6ba1360d31836132188525ad3e298.zip
Old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/synergy')
-rw-r--r--x11-misc/synergy/ChangeLog7
-rw-r--r--x11-misc/synergy/files/synergy-1.4.12-cryptopp.patch74
-rw-r--r--x11-misc/synergy/synergy-1.4.10.ebuild84
-rw-r--r--x11-misc/synergy/synergy-1.4.12.ebuild96
4 files changed, 6 insertions, 255 deletions
diff --git a/x11-misc/synergy/ChangeLog b/x11-misc/synergy/ChangeLog
index b4e91c0659e6..e07c8b17bb8b 100644
--- a/x11-misc/synergy/ChangeLog
+++ b/x11-misc/synergy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/synergy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy/ChangeLog,v 1.104 2013/11/02 09:58:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy/ChangeLog,v 1.105 2013/11/02 16:24:15 jer Exp $
+
+ 02 Nov 2013; Jeroen Roovers <jer@gentoo.org>
+ -files/synergy-1.4.12-cryptopp.patch, -synergy-1.4.10.ebuild,
+ -synergy-1.4.12.ebuild:
+ Old.
02 Nov 2013; Agostino Sarubbo <ago@gentoo.org> synergy-1.4.15.ebuild:
Stable for x86, wrt bug #489482
diff --git a/x11-misc/synergy/files/synergy-1.4.12-cryptopp.patch b/x11-misc/synergy/files/synergy-1.4.12-cryptopp.patch
deleted file mode 100644
index 3ed5b1864d67..000000000000
--- a/x11-misc/synergy/files/synergy-1.4.12-cryptopp.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- a/tools/CMakeLists.txt
-+++ b/tools/CMakeLists.txt
-@@ -13,24 +13,6 @@
- # You should have received a copy of the GNU General Public License
- # along with this program. If not, see <http://www.gnu.org/licenses/>.
-
--set(cpp_dir cryptopp562)
--
--file(GLOB cpp_src ${cpp_dir}/*.cpp)
--
--if (WIN32)
-- file(GLOB cpp_hdr ${cpp_dir}/*.h)
-- list(APPEND cpp_src ${cpp_hdr})
--endif()
--
--file(GLOB cpp_ignore
-- ${cpp_dir}/simple.cpp
-- ${cpp_dir}/strciphr.cpp
-- ${cpp_dir}/polynomi.cpp
-- ${cpp_dir}/eprecomp.cpp
-- ${cpp_dir}/eccrypto.cpp
-- ${cpp_dir}/algebra.cpp)
--list(REMOVE_ITEM cpp_src ${cpp_ignore})
--
- # if 64-bit windows, compile asm file.
- if (CMAKE_CL_64)
- list(APPEND cpp_src ${cpp_dir}/x64dll.asm ${cpp_dir}/x64masm.asm)
-@@ -60,5 +42,3 @@
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
- endif()
- endif()
--
--add_library(cryptopp STATIC ${cpp_src})
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -128,6 +128,10 @@
-
- endif()
-
-+ set(CMAKE_REQUIRED_LIBRARIES crypto++)
-+ set(CMAKE_REQUIRED_LIBRARIES)
-+ set(CMAKE_INCLUDE_DIRECTORIES)
-+
- check_type_size(char SIZEOF_CHAR)
- check_type_size(int SIZEOF_INT)
- check_type_size(long SIZEOF_LONG)
---- a/src/lib/synergy/CCryptoMode.h
-+++ b/src/lib/synergy/CCryptoMode.h
-@@ -17,9 +17,9 @@
-
- #pragma once
-
--#include <cryptopp562/gcm.h>
--#include <cryptopp562/modes.h>
--#include <cryptopp562/aes.h>
-+#include <crypto++/gcm.h>
-+#include <crypto++/modes.h>
-+#include <crypto++/aes.h>
- #include "ECryptoMode.h"
- #include "CString.h"
-
---- a/src/lib/synergy/CCryptoStream.h
-+++ b/src/lib/synergy/CCryptoStream.h
-@@ -20,8 +20,8 @@
- #include "BasicTypes.h"
- #include "CStreamFilter.h"
- #include "CCryptoMode.h"
--#include <cryptopp562/osrng.h>
--#include <cryptopp562/sha.h>
-+#include <crypto++/osrng.h>
-+#include <crypto++/sha.h>
-
- class CCryptoOptions;
-
diff --git a/x11-misc/synergy/synergy-1.4.10.ebuild b/x11-misc/synergy/synergy-1.4.10.ebuild
deleted file mode 100644
index 9b57fcf89e5b..000000000000
--- a/x11-misc/synergy/synergy-1.4.10.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy/synergy-1.4.10.ebuild,v 1.8 2013/03/02 23:53:33 hwoarang Exp $
-
-EAPI=4
-
-inherit eutils flag-o-matic gnome2-utils cmake-utils qt4-r2
-
-DESCRIPTION="Lets you easily share a single mouse and keyboard between multiple computers."
-HOMEPAGE="http://synergy-foss.org/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}-Source.tar.gz
- http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="qt4"
-
-RDEPEND="x11-libs/libXtst
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXinerama
- qt4? ( dev-qt/qtgui:4 )
- qt4? ( !x11-misc/qsynergy )"
-DEPEND="${RDEPEND}
- x11-proto/xextproto
- x11-proto/xproto
- x11-proto/kbproto
- x11-proto/xineramaproto
- x11-libs/libXt"
-
-S=${WORKDIR}/${P}-Source
-
-src_configure() {
- # 1.4.4+ : http://synergy-foss.org/pm/issues/3016
- append-ldflags $(no-as-needed)
-
- cmake-utils_src_configure
-
- if use qt4 ; then
- cd src/gui
- qt4-r2_src_configure
- fi
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- if use qt4 ; then
- cd src/gui
- qt4-r2_src_compile
- fi
-}
-
-src_install () {
- dobin bin/${PN}{c,s}
-
- if use qt4 ; then
- newbin bin/${PN} qsynergy
- newicon -s 256 "${DISTDIR}"/${PN}.png q${PN}.png
- make_desktop_entry q${PN} ${PN/s/S} q${PN} Utility;
- fi
-
- insinto /etc
- newins doc/synergy.conf.example synergy.conf
-
- mv doc/${PN}c.man doc/${PN}c.1 || die
- mv doc/${PN}s.man doc/${PN}s.1 || die
- doman doc/${PN}{c,s}.1
-
- dodoc README doc/synergy.conf.example* ChangeLog
-}
-
-pkg_preinst() {
- use qt4 && gnome2_icon_savelist
-}
-
-pkg_postinst() {
- use qt4 && gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- use qt4 && gnome2_icon_cache_update
-}
diff --git a/x11-misc/synergy/synergy-1.4.12.ebuild b/x11-misc/synergy/synergy-1.4.12.ebuild
deleted file mode 100644
index dea03f2d1f57..000000000000
--- a/x11-misc/synergy/synergy-1.4.12.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy/synergy-1.4.12.ebuild,v 1.4 2013/10/26 15:59:06 jer Exp $
-
-EAPI=5
-
-inherit eutils flag-o-matic gnome2-utils cmake-utils qt4-r2
-
-DESCRIPTION="Lets you easily share a single mouse and keyboard between multiple computers."
-HOMEPAGE="http://synergy-foss.org/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}-Source.tar.gz
- http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="qt4"
-
-COMMON_DEPEND="
- dev-libs/crypto++
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXtst
- qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
-"
-DEPEND="${COMMON_DEPEND}
- x11-proto/kbproto
- x11-proto/randrproto
- x11-proto/xextproto
- x11-proto/xineramaproto
- x11-proto/xproto
-"
-RDEPEND="${COMMON_DEPEND}
- qt4? ( !x11-misc/qsynergy )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-pthread.patch"
- "${FILESDIR}/${P}-cryptopp.patch"
-)
-
-S=${WORKDIR}/${P}-Source
-
-src_configure() {
- cmake-utils_src_configure
-
- if use qt4 ; then
- cd src/gui
- qt4-r2_src_configure
- fi
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- if use qt4 ; then
- cd src/gui
- qt4-r2_src_compile
- fi
-}
-
-src_install () {
- dobin bin/${PN}{c,s}
-
- if use qt4 ; then
- newbin bin/${PN} qsynergy
- newicon -s 256 "${DISTDIR}"/${PN}.png q${PN}.png
- make_desktop_entry q${PN} ${PN/s/S} q${PN} Utility;
- fi
-
- insinto /etc
- newins doc/synergy.conf.example synergy.conf
-
- mv doc/${PN}c.man doc/${PN}c.1 || die
- mv doc/${PN}s.man doc/${PN}s.1 || die
- doman doc/${PN}{c,s}.1
-
- dodoc README doc/synergy.conf.example* ChangeLog
-}
-
-pkg_preinst() {
- use qt4 && gnome2_icon_savelist
-}
-
-pkg_postinst() {
- use qt4 && gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- use qt4 && gnome2_icon_cache_update
-}