summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:47:46 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:47:46 +0000
commit85e56187cea7e21af9262d5410ee8ce27903c535 (patch)
treeecc9c3df2cc7ecdc7b246e262e8e60839654c020 /x11-misc/sw-notify-send
parentImport the live ebuild. (diff)
downloadgentoo-2-85e56187cea7e21af9262d5410ee8ce27903c535.tar.gz
gentoo-2-85e56187cea7e21af9262d5410ee8ce27903c535.tar.bz2
gentoo-2-85e56187cea7e21af9262d5410ee8ce27903c535.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'x11-misc/sw-notify-send')
-rw-r--r--x11-misc/sw-notify-send/ChangeLog9
-rw-r--r--x11-misc/sw-notify-send/metadata.xml2
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-9999.ebuild51
3 files changed, 59 insertions, 3 deletions
diff --git a/x11-misc/sw-notify-send/ChangeLog b/x11-misc/sw-notify-send/ChangeLog
index 77fee835f6a1..a2763cfc87bc 100644
--- a/x11-misc/sw-notify-send/ChangeLog
+++ b/x11-misc/sw-notify-send/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/sw-notify-send
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sw-notify-send/ChangeLog,v 1.8 2012/05/05 04:53:48 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sw-notify-send/ChangeLog,v 1.9 2012/12/15 12:47:46 mgorny Exp $
+
+*sw-notify-send-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +sw-notify-send-9999.ebuild,
+ metadata.xml:
+ Import the live ebuild.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> sw-notify-send-1.2.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -45,4 +51,3 @@
+metadata.xml:
A new ebuild for sw-notify-send, a system-wide notify-send wrapper. Moved
from Sunrise per bug #318961.
-
diff --git a/x11-misc/sw-notify-send/metadata.xml b/x11-misc/sw-notify-send/metadata.xml
index f37add7f2dc8..ffbaa73c6e13 100644
--- a/x11-misc/sw-notify-send/metadata.xml
+++ b/x11-misc/sw-notify-send/metadata.xml
@@ -10,6 +10,6 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/tinynotify-send/issues/</bugs-to>
+ <bugs-to>https://bitbucket.org/mgorny/tinynotify-send/issues/</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
new file mode 100644
index 000000000000..2c6a5780b7cc
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sw-notify-send/sw-notify-send-9999.ebuild,v 1.1 2012/12/15 12:47:46 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/tinynotify-send.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils
+
+MY_PN=tinynotify-send
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A system-wide variant of tinynotify-send"
+HOMEPAGE="https://bitbucket.org/mgorny/tinynotify-send/"
+SRC_URI="mirror://bitbucket/mgorny/${MY_PN}/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libtinynotify
+ ~x11-libs/libtinynotify-cli-${PV}
+ x11-libs/libtinynotify-systemwide"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ dev-util/gtk-doc"
+#endif
+
+src_configure() {
+ myeconfargs=(
+ --disable-library
+ --disable-regular
+ --enable-system-wide
+ )
+
+ autotools-utils_src_configure
+}