summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-09-15 20:11:32 +0000
committerJeroen Roovers <jer@gentoo.org>2008-09-15 20:11:32 +0000
commitb7a6f757909398cd864ff7c772a64a2b990abc16 (patch)
treefe33d8feba962a50381100be32cb7f994773e00f /x11-misc/sselp
parentbump to 0.7.0_rc5 (diff)
downloadgentoo-2-b7a6f757909398cd864ff7c772a64a2b990abc16.tar.gz
gentoo-2-b7a6f757909398cd864ff7c772a64a2b990abc16.tar.bz2
gentoo-2-b7a6f757909398cd864ff7c772a64a2b990abc16.zip
Add live ebuild. Improve sed substitions for the static ebuild.
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'x11-misc/sselp')
-rw-r--r--x11-misc/sselp/ChangeLog8
-rw-r--r--x11-misc/sselp/sselp-0.2.ebuild8
-rw-r--r--x11-misc/sselp/sselp-9999.ebuild36
3 files changed, 47 insertions, 5 deletions
diff --git a/x11-misc/sselp/ChangeLog b/x11-misc/sselp/ChangeLog
index 60862c396475..c8560512e3f6 100644
--- a/x11-misc/sselp/ChangeLog
+++ b/x11-misc/sselp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/sselp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sselp/ChangeLog,v 1.1 2008/09/14 20:35:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sselp/ChangeLog,v 1.2 2008/09/15 20:11:32 jer Exp $
+
+*sselp-9999 (15 Sep 2008)
+
+ 15 Sep 2008; Jeroen Roovers <jer@gentoo.org> sselp-0.2.ebuild,
+ +sselp-9999.ebuild:
+ Add live ebuild. Improve sed substitions for the static ebuild.
*sselp-0.2 (14 Sep 2008)
diff --git a/x11-misc/sselp/sselp-0.2.ebuild b/x11-misc/sselp/sselp-0.2.ebuild
index 26ebd43d4619..f546d612923e 100644
--- a/x11-misc/sselp/sselp-0.2.ebuild
+++ b/x11-misc/sselp/sselp-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sselp/sselp-0.2.ebuild,v 1.2 2008/09/14 23:26:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sselp/sselp-0.2.ebuild,v 1.3 2008/09/15 20:11:32 jer Exp $
inherit toolchain-funcs
@@ -21,9 +21,9 @@ src_unpack() {
cd "${S}"
sed -i \
- -e "s|CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall -g|" \
- -e "s|LDFLAGS = -s|LDFLAGS += -g|" \
- -e "s|CC = cc|CC = $(tc-getCC)|g" \
+ -e "s|^CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall|" \
+ -e "s|^LDFLAGS = -s|LDFLAGS +=|" \
+ -e "s|^CC = cc|CC = $(tc-getCC)|" \
config.mk || die "sed failed"
}
diff --git a/x11-misc/sselp/sselp-9999.ebuild b/x11-misc/sselp/sselp-9999.ebuild
new file mode 100644
index 000000000000..7a8ad36d4b13
--- /dev/null
+++ b/x11-misc/sselp/sselp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sselp/sselp-9999.ebuild,v 1.1 2008/09/15 20:11:32 jer Exp $
+
+inherit mercurial toolchain-funcs
+
+DESCRIPTION="Simple X selection printer"
+HOMEPAGE="http://www.suckless.org/programs/sselp.html"
+SRC_URI=""
+EHG_REPO_URI=http://code.suckless.org/hg/${PN}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ mercurial_src_unpack
+ cd "${S}"
+
+ sed -i \
+ -e "s|^CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall|" \
+ -e "s|^LDFLAGS = -s|LDFLAGS +=|" \
+ -e "s|^CC = cc|CC = $(tc-getCC)|" \
+ config.mk || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+ dodoc README
+}