summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-07-31 02:58:40 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-07-31 02:58:40 +0000
commitc11cbb40574931fc05629429395faf0f8a4f04ef (patch)
tree5208015952a3e67481b31cc5b5848201b02b2125 /x11-misc/slim
parentVersion bump, Bug #327267. Thanks cilly. (diff)
downloadgentoo-2-c11cbb40574931fc05629429395faf0f8a4f04ef.tar.gz
gentoo-2-c11cbb40574931fc05629429395faf0f8a4f04ef.tar.bz2
gentoo-2-c11cbb40574931fc05629429395faf0f8a4f04ef.zip
Upstream version bump with minor changes, bug 328447. Drop screenshot USE flag and suggest a method with comments in the conf file, bug 252241
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/slim')
-rw-r--r--x11-misc/slim/ChangeLog9
-rw-r--r--x11-misc/slim/files/slim-1.3.2-config.diff57
-rw-r--r--x11-misc/slim/slim-1.3.2.ebuild96
3 files changed, 161 insertions, 1 deletions
diff --git a/x11-misc/slim/ChangeLog b/x11-misc/slim/ChangeLog
index 4f8bd042b4f7..e2fd87c15d4f 100644
--- a/x11-misc/slim/ChangeLog
+++ b/x11-misc/slim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/slim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.50 2010/05/21 22:24:38 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.51 2010/07/31 02:58:39 darkside Exp $
+
+*slim-1.3.2 (31 Jul 2010)
+
+ 31 Jul 2010; Jeremy Olexa <darkside@gentoo.org> +slim-1.3.2.ebuild,
+ +files/slim-1.3.2-config.diff:
+ Upstream version bump with minor changes, bug 328447. Drop screenshot USE
+ flag and suggest a method with comments in the conf file, bug 252241
21 May 2010; Jeremy Olexa <darkside@gentoo.org> -slim-1.3.1-r4.ebuild,
-slim-1.3.1-r5.ebuild, slim-1.3.1_p20091114.ebuild:
diff --git a/x11-misc/slim/files/slim-1.3.2-config.diff b/x11-misc/slim/files/slim-1.3.2-config.diff
new file mode 100644
index 000000000000..e05711b41c14
--- /dev/null
+++ b/x11-misc/slim/files/slim-1.3.2-config.diff
@@ -0,0 +1,57 @@
+--- slim.conf.orig 2010-07-08 00:04:10.000000000 -0500
++++ slim.conf 2010-07-30 21:46:14.713367279 -0500
+@@ -2,7 +2,7 @@
+ # Note: -xauth $authfile is automatically appended
+ default_path /bin:/usr/bin:/usr/local/bin
+ default_xserver /usr/bin/X
+-#xserver_arguments -dpi 75
++xserver_arguments -nolisten tcp -br -deferglyphs 16
+
+ # Commands for halt, login, etc.
+ halt_cmd /sbin/shutdown -h now
+@@ -18,7 +18,7 @@
+
+
+ # Activate numlock when slim starts. Valid values: on|off
+-# numlock on
++numlock on
+
+ # Hide the mouse cursor (note: does not work with some WMs).
+ # Valid values: true|false
+@@ -33,7 +33,8 @@
+ # to adjust the command according to your preferred shell,
+ # i.e. for freebsd use:
+ # login_cmd exec /bin/sh - ~/.xinitrc %session
+-login_cmd exec /bin/bash -login ~/.xinitrc %session
++# login_cmd exec /bin/bash -login ~/.xinitrc %session
++login_cmd exec /bin/bash -login /etc/X11/xinit/xinitrc
+
+ # Commands executed when starting and exiting a session.
+ # They can be used for registering a X11 session with
+@@ -41,11 +42,13 @@
+ #
+ # sessionstart_cmd some command
+ # sessionstop_cmd some command
++sessionstart_cmd /usr/bin/sessreg -a -l :0.0 %user
++sessionstop_cmd /usr/bin/sessreg -d -l :0.0 %user
+
+ # Start in daemon mode. Valid values: yes | no
+ # Note that this can be overriden by the command line
+ # options "-d" and "-nodaemon"
+-# daemon yes
++daemon yes
+
+ # Available sessions (first one is the default).
+ # The current chosen session name is replaced in the login_cmd
+@@ -53,8 +56,10 @@
+ # see the xinitrc.sample file shipped with slim sources
+ sessions xfce4,icewm,wmaker,blackbox
+
+-# Executed when pressing F11 (requires imagemagick)
++# Executed when pressing F11 (requires media-gfx/imagemagick for import)
++# Alternative is media-gfx/scrot. See Gentoo bug 252241 for more info.
+ screenshot_cmd import -window root /slim.png
++#screenshot_cmd scrot /root/slim.png
+
+ # welcome message. Available variables: %host, %domain
+ welcome_msg Welcome to %host
diff --git a/x11-misc/slim/slim-1.3.2.ebuild b/x11-misc/slim/slim-1.3.2.ebuild
new file mode 100644
index 000000000000..6f3196666045
--- /dev/null
+++ b/x11-misc/slim/slim-1.3.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.2.ebuild,v 1.1 2010/07/31 02:58:39 darkside Exp $
+
+EAPI=2
+
+inherit toolchain-funcs pam eutils
+
+DESCRIPTION="Simple Login Manager"
+HOMEPAGE="http://slim.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="branding screenshot pam"
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXft
+ media-libs/libpng
+ media-libs/jpeg
+ x11-apps/sessreg
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+PDEPEND="branding? ( >=x11-themes/slim-themes-1.2.3a-r3 )"
+
+src_prepare() {
+ # respect C[XX]FLAGS, fix crosscompile,
+ # fix linking order for --as-needed"
+ sed -i -e "s:^CXX=.*:CXX=$(tc-getCXX) ${CXXFLAGS}:" \
+ -e "s:^CC=.*:CC=$(tc-getCC) ${CFLAGS}:" \
+ -e "s:^MANDIR=.*:MANDIR=/usr/share/man:" \
+ -e "s:^\t\(.*\)\ \$(LDFLAGS)\ \(.*\):\t\1\ \2\ \$(LDFLAGS):g" \
+ -e "s:-I/usr/include/libpng12:$(pkg-config --cflags-only-I libpng):" \
+ -e "s:-lpng12:$(pkg-config --libs-only-l libpng):" \
+ -r -e "s:^LDFLAGS=(.*):LDFLAGS=\1 ${LDFLAGS}:" \
+ Makefile || die "sed failed in Makefile"
+ epatch "${FILESDIR}/${PN}-1.3.2-config.diff"
+
+ if use branding; then
+ sed -i -e 's/ default/ slim-gentoo-simple/' slim.conf || die
+ fi
+
+ # Gentoo bug 297655
+ epatch "${FILESDIR}/14509-fix-keyboard-in-tty-from-which-${PN}-is-lauched.patch"
+ # Upstream bug #15287
+ epatch "${FILESDIR}/15287-fix-pam-authentication-with-pam_unix2.patch"
+ # Gentoo Bug 261713
+ epatch "${FILESDIR}/261713-restart-xserver-if-killed.patch"
+}
+
+src_compile() {
+ if use pam ; then
+ emake USE_PAM=1 || die "emake failed."
+ else
+ emake || die "emake failed."
+ fi
+}
+
+src_install() {
+ if use pam ; then
+ emake USE_PAM=1 DESTDIR="${D}" install || die "emake install failed."
+ pamd_mimic_system slim auth account password session
+ else
+ emake DESTDIR="${D}" install || die "emake install failed."
+ fi
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/slim.logrotate" slim || die "newins failed"
+
+ dodoc xinitrc.sample ChangeLog README TODO THEMES
+}
+
+pkg_postinst() {
+ elog
+ elog "The configuration file is located at /etc/slim.conf."
+ elog
+ elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
+ elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
+ elog "By default, ${PN} will use default XSESSION value set in /etc/rc.conf."
+ elog
+ elog "If you want to use .xinitrc in the user's home directory for session"
+ elog "management instead, see README and xinitrc.sample in"
+ elog "/usr/share/doc/${PF} and change your login_cmd in /etc/slim.conf"
+ elog "accordingly."
+ elog
+ if ! use pam; then
+ elog "You have merged ${PN} without USE=pam, this will cause ${PN} to fall back to"
+ elog "the console when restarting your window manager. If this is not"
+ elog "desired, then please remerge ${PN} with USE=pam"
+ fi
+}