summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-13 19:38:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-13 19:38:09 +0000
commit931a5352cda8f26f55fe4c62d5794b19725efebc (patch)
treefe53d3e65a7481d54aa2cb08fd92f04f948c05bb /x11-misc/screengrab
parentFix bug 390439 by setting properly get_libdir (diff)
downloadgentoo-2-931a5352cda8f26f55fe4c62d5794b19725efebc.tar.gz
gentoo-2-931a5352cda8f26f55fe4c62d5794b19725efebc.tar.bz2
gentoo-2-931a5352cda8f26f55fe4c62d5794b19725efebc.zip
Respect CXXFLAGS thanks to Agostino Sarubbo (ago). Bug #387741
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/screengrab')
-rw-r--r--x11-misc/screengrab/ChangeLog5
-rw-r--r--x11-misc/screengrab/screengrab-0.9.85.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/x11-misc/screengrab/ChangeLog b/x11-misc/screengrab/ChangeLog
index 7e4c3271c7bc..e023bc766f85 100644
--- a/x11-misc/screengrab/ChangeLog
+++ b/x11-misc/screengrab/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/screengrab
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/screengrab/ChangeLog,v 1.15 2011/08/19 21:29:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/screengrab/ChangeLog,v 1.16 2011/11/13 19:38:09 hwoarang Exp $
+
+ 13 Nov 2011; Markos Chandras <hwoarang@gentoo.org> screengrab-0.9.85.ebuild:
+ Respect CXXFLAGS thanks to Agostino Sarubbo (ago). Bug #387741
*screengrab-0.9.85 (19 Aug 2011)
diff --git a/x11-misc/screengrab/screengrab-0.9.85.ebuild b/x11-misc/screengrab/screengrab-0.9.85.ebuild
index e6e0fefdb33d..a589750e8526 100644
--- a/x11-misc/screengrab/screengrab-0.9.85.ebuild
+++ b/x11-misc/screengrab/screengrab-0.9.85.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/screengrab/screengrab-0.9.85.ebuild,v 1.1 2011/08/19 21:29:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/screengrab/screengrab-0.9.85.ebuild,v 1.2 2011/11/13 19:38:09 hwoarang Exp $
EAPI="2"
@@ -23,7 +23,8 @@ src_prepare() {
sed -i "/LICENSE.txt/d" CMakeLists.txt \
|| die "failed to patch cmakelists"
# install docs in the right dir
- sed -i "s#DESTINATION share/doc/screengrab#DESTINATION share/doc/${PF}#" \
+ sed -i -e "s#DESTINATION share/doc/screengrab#DESTINATION share/doc/${PF}#" \
+ -e "s:-Wnon-virtual-dtor -Woverloaded-virtual:${CXXFLAGS}:" \
CMakeLists.txt || die "failed to patch doc dir"
sed -i "s:screengrab%1html:${PF}%1html:" src/ui/mainwindow.cpp || die
}