summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2014-04-13 17:51:27 +0000
committerSebastian Pipping <sping@gentoo.org>2014-04-13 17:51:27 +0000
commit1271efefddfff7d281c88f72c75201b00686c2c7 (patch)
tree3a45cfdd165e6f13a660e1d37d7d20bbb630face /x11-misc/redshift/redshift-1.9-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-1271efefddfff7d281c88f72c75201b00686c2c7.tar.gz
gentoo-2-1271efefddfff7d281c88f72c75201b00686c2c7.tar.bz2
gentoo-2-1271efefddfff7d281c88f72c75201b00686c2c7.zip
x11-misc/redshift: Apply upstream patch
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'x11-misc/redshift/redshift-1.9-r1.ebuild')
-rw-r--r--x11-misc/redshift/redshift-1.9-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/redshift/redshift-1.9-r1.ebuild b/x11-misc/redshift/redshift-1.9-r1.ebuild
new file mode 100644
index 000000000000..f688a1a6b315
--- /dev/null
+++ b/x11-misc/redshift/redshift-1.9-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/redshift/redshift-1.9-r1.ebuild,v 1.1 2014/04/13 17:51:26 sping Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit autotools eutils gnome2-utils python-r1
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="http://jonls.dk/redshift/"
+SRC_URI="https://github.com/jonls/redshift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoclue gtk nls"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ x11-libs/libdrm
+ geoclue? ( app-misc/geoclue:0 dev-libs/glib:2 )
+ gtk? ( ${PYTHON_DEPS} )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-toggle.patch
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ python_export_best
+
+ econf \
+ --disable-silent-rules \
+ $(use_enable nls) \
+ --enable-drm \
+ --enable-randr \
+ --enable-vidmode \
+ --disable-wingdi \
+ $(use_enable geoclue) \
+ $(use_enable gtk gui) \
+ --disable-ubuntu
+}
+
+_impl_specific_src_install() {
+ emake DESTDIR="${D}" pythondir="$(python_get_sitedir)" \
+ -C src/redshift-gtk install
+}
+
+src_install() {
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=/bin/true install
+
+ if use gtk; then
+ python_foreach_impl _impl_specific_src_install
+ python_replicate_script "${D}"/usr/bin/redshift-gtk
+ dosym redshift-gtk /usr/bin/gtk-redshift
+ fi
+}
+
+pkg_preinst() {
+ use gtk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}