summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-04 07:53:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-04 07:53:07 +0000
commitc9c8bfd835df235623c1337d9a4850269423d81f (patch)
tree1b848d92b9e5d940cea4d1ad17884d68c365a1aa /x11-misc/rednotebook
parentStable on amd64 wrt bug #331151 (diff)
downloadgentoo-2-c9c8bfd835df235623c1337d9a4850269423d81f.tar.gz
gentoo-2-c9c8bfd835df235623c1337d9a4850269423d81f.tar.bz2
gentoo-2-c9c8bfd835df235623c1337d9a4850269423d81f.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog8
-rw-r--r--x11-misc/rednotebook/rednotebook-1.1.0.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index e2490842e633..529c401a0036 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.35 2010/07/29 11:56:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.36 2010/08/04 07:53:07 hwoarang Exp $
+
+*rednotebook-1.1.0 (04 Aug 2010)
+
+ 04 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +rednotebook-1.1.0.ebuild:
+ Version bump
29 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
-rednotebook-0.9.0.ebuild, -rednotebook-0.9.2.ebuild,
diff --git a/x11-misc/rednotebook/rednotebook-1.1.0.ebuild b/x11-misc/rednotebook/rednotebook-1.1.0.ebuild
new file mode 100644
index 000000000000..37b59758406f
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.1.0.ebuild,v 1.1 2010/08/04 07:53:07 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/${PN}-0.9.3-disable-webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-0.8.9_disable_spell.patch"
+ distutils_src_prepare
+}