summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-02-06 15:12:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-02-06 15:12:32 +0000
commit9b94fea90d08e50b6c2b0544a4a7708087eff716 (patch)
tree2d5371158828b12baa22ec73923d144b2af2c79b /x11-misc/rednotebook
parentUse $(PYTHON -f) instead of ${python}. (diff)
downloadgentoo-2-9b94fea90d08e50b6c2b0544a4a7708087eff716.tar.gz
gentoo-2-9b94fea90d08e50b6c2b0544a4a7708087eff716.tar.bz2
gentoo-2-9b94fea90d08e50b6c2b0544a4a7708087eff716.zip
Version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog8
-rw-r--r--x11-misc/rednotebook/files/disable_webkit.patch27
-rw-r--r--x11-misc/rednotebook/metadata.xml1
-rw-r--r--x11-misc/rednotebook/rednotebook-0.9.2.ebuild28
4 files changed, 63 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 9588cae6e8af..36029e538bb0 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.24 2010/01/31 16:48:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.25 2010/02/06 15:12:31 hwoarang Exp $
+
+*rednotebook-0.9.2 (06 Feb 2010)
+
+ 06 Feb 2010; Markos Chandras <hwoarang@gentoo.org>
+ +rednotebook-0.9.2.ebuild, +files/disable_webkit.patch, metadata.xml:
+ Version bump
31 Jan 2010; <hwoarang@gentoo.org> rednotebook-0.9.0.ebuild:
Stable on amd64 wrt bug #302352
diff --git a/x11-misc/rednotebook/files/disable_webkit.patch b/x11-misc/rednotebook/files/disable_webkit.patch
new file mode 100644
index 000000000000..a770b439c83c
--- /dev/null
+++ b/x11-misc/rednotebook/files/disable_webkit.patch
@@ -0,0 +1,27 @@
+Index: rednotebook-0.9.2/rednotebook/gui/browser.py
+===================================================================
+--- rednotebook-0.9.2.orig/rednotebook/gui/browser.py
++++ rednotebook-0.9.2/rednotebook/gui/browser.py
+@@ -28,6 +28,8 @@ import warnings
+ import gtk
+ import gobject
+
++webkit = None
++
+ # Testing
+ if __name__ == '__main__':
+ sys.path.insert(0, '../../')
+@@ -35,13 +37,6 @@ if __name__ == '__main__':
+ #gtk.gdk.threads_init() # only initializes threading in the glib/gobject module
+ gobject.threads_init() # also initializes the gdk threads
+
+-
+-try:
+- import webkit
+-except ImportError:
+- logging.info('Importing webkit failed')
+- webkit = None
+-
+ from rednotebook.util import filesystem
+
+
diff --git a/x11-misc/rednotebook/metadata.xml b/x11-misc/rednotebook/metadata.xml
index cb0e95093e87..3f35d257e54b 100644
--- a/x11-misc/rednotebook/metadata.xml
+++ b/x11-misc/rednotebook/metadata.xml
@@ -4,6 +4,7 @@
<herd>no-herd</herd>
<use>
<flag name='libyaml'>enable libyaml support</flag>
+ <flag name='webkit'>enable previews using webkit engine</flag>
</use>
<maintainer>
<email>hwoarang@gentoo.org</email>
diff --git a/x11-misc/rednotebook/rednotebook-0.9.2.ebuild b/x11-misc/rednotebook/rednotebook-0.9.2.ebuild
new file mode 100644
index 000000000000..c696a0faca06
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-0.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-0.9.2.ebuild,v 1.1 2010/02/06 15:12:31 hwoarang Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.6"
+inherit eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/disable_webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-0.8.9_disable_spell.patch"
+ distutils_src_prepare
+}