summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-22 12:42:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-22 12:42:50 +0000
commit61844553daddf1da9eb37dd77b0c55c36b9abad2 (patch)
tree96593f852ea1deab40b035586beccd28abcea4a3 /x11-misc/rednotebook
parentRemove unused file. (diff)
downloadgentoo-2-61844553daddf1da9eb37dd77b0c55c36b9abad2.tar.gz
gentoo-2-61844553daddf1da9eb37dd77b0c55c36b9abad2.tar.bz2
gentoo-2-61844553daddf1da9eb37dd77b0c55c36b9abad2.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog8
-rw-r--r--x11-misc/rednotebook/files/rednotebook-1.1.1-disable-webkit.patch45
-rw-r--r--x11-misc/rednotebook/rednotebook-1.1.1.ebuild32
3 files changed, 84 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index cd9b12c20f2d..a892c2c2de02 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.37 2010/08/05 21:04:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.38 2010/08/22 12:42:49 hwoarang Exp $
+
+*rednotebook-1.1.1 (22 Aug 2010)
+
+ 22 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +rednotebook-1.1.1.ebuild, +files/rednotebook-1.1.1-disable-webkit.patch:
+ Version bump
05 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
-rednotebook-1.0.0.ebuild, rednotebook-1.1.0.ebuild,
diff --git a/x11-misc/rednotebook/files/rednotebook-1.1.1-disable-webkit.patch b/x11-misc/rednotebook/files/rednotebook-1.1.1-disable-webkit.patch
new file mode 100644
index 000000000000..10c601bf20b0
--- /dev/null
+++ b/x11-misc/rednotebook/files/rednotebook-1.1.1-disable-webkit.patch
@@ -0,0 +1,45 @@
+Index: rednotebook-1.1.1/rednotebook/gui/browser.py
+===================================================================
+--- rednotebook-1.1.1.orig/rednotebook/gui/browser.py
++++ rednotebook-1.1.1/rednotebook/gui/browser.py
+@@ -40,40 +40,6 @@ from rednotebook.util import filesystem
+
+ webkit = None
+
+-def windows_webkit_import():
+- global webkit
+-
+- cwd = os.getcwd()
+-
+- if filesystem.main_is_frozen():
+- gtk_bin_dir = filesystem.app_dir
+- else:
+- gtk_bin_dir = r'C:\GTK'
+-
+- try:
+- # It seems the dlls are only found if we are in the bin dir
+- # during import
+- os.chdir(gtk_bin_dir)
+- except WindowsError:
+- logging.error('Changing dir to "%s" failed' % gtk_bin_dir)
+- return
+-
+- try:
+- import webkit
+- except ImportError:
+- logging.info('webkit not found. For a nicer preview install python-webkit or pywebkitgtk')
+- os.chdir(cwd)
+-
+-if False and sys.platform == 'win32':
+- windows_webkit_import()
+-else:
+- try:
+- import webkit
+- except ImportError:
+- logging.info('webkit not found. For a nicer preview install python-webkit or pywebkitgtk')
+-
+-
+-
+ def can_print_pdf():
+ if not webkit:
+ return False
diff --git a/x11-misc/rednotebook/rednotebook-1.1.1.ebuild b/x11-misc/rednotebook/rednotebook-1.1.1.ebuild
new file mode 100644
index 000000000000..c3af3aabf52f
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.1.1.ebuild,v 1.1 2010/08/22 12:42:50 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell webkit"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ spell? ( dev-python/gtkspell-python )
+ webkit? ( dev-python/pywebkitgtk )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ ! use webkit && epatch "${FILESDIR}/${P}-disable-webkit.patch"
+ ! use spell && epatch "${FILESDIR}/${PN}-1.1.0-disable-spell.patch"
+ distutils_src_prepare
+}