summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-09-04 23:41:59 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-09-04 23:41:59 +0000
commite7af24af17a159b4b34703bf4d89d376c99c66ac (patch)
tree2182b3282cfd0de5f0abad6689185cc535b64e52 /x11-misc/notification-daemon
parentBump to 3.4.3 (diff)
downloadgentoo-2-e7af24af17a159b4b34703bf4d89d376c99c66ac.tar.gz
gentoo-2-e7af24af17a159b4b34703bf4d89d376c99c66ac.tar.bz2
gentoo-2-e7af24af17a159b4b34703bf4d89d376c99c66ac.zip
Bump to 0.7.6; translation updates and bug fixes
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/notification-daemon')
-rw-r--r--x11-misc/notification-daemon/ChangeLog9
-rw-r--r--x11-misc/notification-daemon/notification-daemon-0.7.6.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/x11-misc/notification-daemon/ChangeLog b/x11-misc/notification-daemon/ChangeLog
index e335154a60ed..fc032f0784a6 100644
--- a/x11-misc/notification-daemon/ChangeLog
+++ b/x11-misc/notification-daemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/notification-daemon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.89 2012/06/02 12:29:22 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.90 2012/09/04 23:41:59 nirbheek Exp $
+
+*notification-daemon-0.7.6 (04 Sep 2012)
+
+ 04 Sep 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +notification-daemon-0.7.6.ebuild:
+ Bump to 0.7.6; translation updates and bug fixes
02 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
notification-daemon-0.7.4.ebuild:
@@ -397,4 +403,3 @@
19 Feb 2006; Sven Wegener <swegener@gentoo.org> +metadata.xml,
+notification-daemon-0.3.4.ebuild:
Initial commit, ebuild written by me.
-
diff --git a/x11-misc/notification-daemon/notification-daemon-0.7.6.ebuild b/x11-misc/notification-daemon/notification-daemon-0.7.6.ebuild
new file mode 100644
index 000000000000..f7d0d56bc5cd
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-0.7.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.7.6.ebuild,v 1.1 2012/09/04 23:41:59 nirbheek Exp $
+
+EAPI=4
+inherit gnome.org
+
+DESCRIPTION="Notification daemon"
+HOMEPAGE="http://git.gnome.org/browse/notification-daemon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.28
+ x11-libs/gtk+:3
+ sys-apps/dbus
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ default
+
+ cat <<-EOF > "${T}"/org.freedesktop.Notifications.service
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/notification-daemon
+ EOF
+
+ insinto /usr/share/dbus-1/services
+ doins "${T}"/org.freedesktop.Notifications.service
+}