summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-07-27 07:02:03 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-07-27 07:02:03 +0000
commit3b2474a1e92176d4fb586969ec8081ed78c39a57 (patch)
treeb1829516708e01fd827089ac9433dcacdb5fb18f /x11-misc/notification-daemon
parentAdded missing pam flag to IUSE (diff)
downloadgentoo-2-3b2474a1e92176d4fb586969ec8081ed78c39a57.tar.gz
gentoo-2-3b2474a1e92176d4fb586969ec8081ed78c39a57.tar.bz2
gentoo-2-3b2474a1e92176d4fb586969ec8081ed78c39a57.zip
Adding data handling patch for notification daemon (bug #137793)
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'x11-misc/notification-daemon')
-rw-r--r--x11-misc/notification-daemon/ChangeLog9
-rw-r--r--x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r13
-rw-r--r--x11-misc/notification-daemon/files/notification-daemon-0.3.5-icon-data.patch62
-rw-r--r--x11-misc/notification-daemon/notification-daemon-0.3.5-r1.ebuild32
4 files changed, 105 insertions, 1 deletions
diff --git a/x11-misc/notification-daemon/ChangeLog b/x11-misc/notification-daemon/ChangeLog
index 6b81e45bae69..9bdc7e25b1ea 100644
--- a/x11-misc/notification-daemon/ChangeLog
+++ b/x11-misc/notification-daemon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/notification-daemon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.13 2006/07/21 02:00:33 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.14 2006/07/27 07:02:03 compnerd Exp $
+
+*notification-daemon-0.3.5-r1 (27 Jul 2006)
+
+ 27 Jul 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/notification-daemon-0.3.5-icon-data.patch,
+ +notification-daemon-0.3.5-r1.ebuild:
+ Adding patch to check the DBUS struct type of the data
21 Jul 2006; Luis Medinas <metalgod@gentoo.org>
notification-daemon-0.3.5.ebuild:
diff --git a/x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r1 b/x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r1
new file mode 100644
index 000000000000..b466389ed87e
--- /dev/null
+++ b/x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r1
@@ -0,0 +1,3 @@
+MD5 7977c4c15139f9d53ddbfa8af707270f notification-daemon-0.3.5.tar.gz 383582
+RMD160 5251ce4dcc2ae3cc637077ea71eb65a17c9102b4 notification-daemon-0.3.5.tar.gz 383582
+SHA256 83a15eb99bb7a895d52e31be1c1548789a8bc29e83d30e758cf034a6627a1184 notification-daemon-0.3.5.tar.gz 383582
diff --git a/x11-misc/notification-daemon/files/notification-daemon-0.3.5-icon-data.patch b/x11-misc/notification-daemon/files/notification-daemon-0.3.5-icon-data.patch
new file mode 100644
index 000000000000..7546f1c603f9
--- /dev/null
+++ b/x11-misc/notification-daemon/files/notification-daemon-0.3.5-icon-data.patch
@@ -0,0 +1,62 @@
+diff -Naur notification-daemon-0.3.5.orig/src/daemon.c notification-daemon-0.3.5/src/daemon.c
+--- notification-daemon-0.3.5.orig/src/daemon.c 2006-04-26 10:32:50.000000000 +0200
++++ notification-daemon-0.3.5/src/daemon.c 2006-06-18 05:07:47.000000000 +0200
+@@ -399,14 +399,54 @@
+ GValueArray *image_struct;
+ GValue *value;
+ GArray *tmp_array;
++ GType type = G_VALUE_TYPE (icon_data);
++
++ static const GType types[] = {
++ G_TYPE_INT,
++ G_TYPE_INT,
++ G_TYPE_INT,
++ G_TYPE_BOOLEAN,
++ G_TYPE_INT,
++ G_TYPE_INT
++ };
++
++
++ if (dbus_g_type_is_struct (type))
++ {
++ int n;
++
++ if (dbus_g_type_get_struct_size (type) < 7)
++ {
++ g_warning("_notify_daemon_process_icon_data expected 7 data members, got only %d", dbus_g_type_get_struct_size (type));
++ return FALSE;
++ }
++
++ for (n = 0; n < G_N_ELEMENTS (types); ++n)
++ {
++ GType check = dbus_g_type_get_struct_member_type (type, n);
++ if (check != types[n])
++ {
++ g_warning("_notify_daemon_process_icon_data expected '%s' at position %d, but got '%s'",
++ g_type_name (types[n]), n, g_type_name (check));
++ return FALSE;
++ }
+
+- if (!G_VALUE_HOLDS(icon_data, G_TYPE_VALUE_ARRAY))
++ /* We must check this separately as it's not a constant and can't be part of the types[] array */
++ if (dbus_g_type_get_struct_member_type (type, 6) != DBUS_TYPE_G_UCHAR_ARRAY)
++ {
++ g_warning("_notify_daemon_process_icon_data expected '%s' at position %d, but got '%s'",
++ g_type_name (DBUS_TYPE_G_UCHAR_ARRAY), 6, g_type_name (dbus_g_type_get_struct_member_type (type,6)));
++ return FALSE;
++ }
++ }
++ }
++ else
+ {
+- g_warning("_notify_daemon_process_icon_data expected a "
+- "GValue of type GValueArray");
+- return FALSE;
++ g_warning("_notify_daemon_process_icon_data got wrong data");
++ return FALSE;
+ }
+
++
+ image_struct = (GValueArray *)g_value_get_boxed(icon_data);
+ value = g_value_array_get_nth(image_struct, 0);
+
diff --git a/x11-misc/notification-daemon/notification-daemon-0.3.5-r1.ebuild b/x11-misc/notification-daemon/notification-daemon-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..56c448ce9d20
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-0.3.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.3.5-r1.ebuild,v 1.1 2006/07/27 07:02:03 compnerd Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Notifications daemon"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=gnome-base/gconf-2.4.0
+ >=x11-libs/libsexy-0.1.3
+ >=sys-apps/dbus-0.36
+ x11-libs/libwnck
+ dev-libs/popt"
+RDEPEND="${DEPEND}
+ >=sys-devel/gettext-0.14"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-0.3.5-icon-data.patch
+}