summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-19 02:14:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-19 02:14:33 +0000
commitf3b030ef02ec2ab553e83efafe64fa4b180d471f (patch)
tree678b7c6bd2a6bac94a6fadffc8ad4afeda4ba615 /x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild
parentold (diff)
downloadgentoo-2-f3b030ef02ec2ab553e83efafe64fa4b180d471f.tar.gz
gentoo-2-f3b030ef02ec2ab553e83efafe64fa4b180d471f.tar.bz2
gentoo-2-f3b030ef02ec2ab553e83efafe64fa4b180d471f.zip
Install org.freedesktop.Notifications.service like it was in 0.5.0.
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild')
-rw-r--r--x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild b/x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild
index d54828c3b91a..306e15270345 100644
--- a/x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild
+++ b/x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild,v 1.1 2011/10/19 02:05:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.7.3.ebuild,v 1.2 2011/10/19 02:14:33 ssuominen Exp $
EAPI=4
inherit gnome.org
@@ -26,3 +26,16 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ default
+
+ cat <<-EOF > "${T}"/org.freedesktop.Notifications.service
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/notification-daemon
+ EOF
+
+ insinto /usr/share/dbus-1/services
+ doins "${T}"/org.freedesktop.Notifications.service
+}