summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-22 05:58:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-22 05:58:35 +0000
commit68fd8d92024063441e8d9e811d6da1a4d78b2b41 (patch)
tree0f59a36b543f65a849be0616deafddc3a5b68c4f /x11-misc/lxmed
parentInitial commit. An XDG compatible menu editor for LXDE, Xfce, etc (diff)
downloadgentoo-2-68fd8d92024063441e8d9e811d6da1a4d78b2b41.tar.gz
gentoo-2-68fd8d92024063441e8d9e811d6da1a4d78b2b41.tar.bz2
gentoo-2-68fd8d92024063441e8d9e811d6da1a4d78b2b41.zip
simplify a bit for prev commit
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/lxmed')
-rw-r--r--x11-misc/lxmed/lxmed-20110717.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11-misc/lxmed/lxmed-20110717.ebuild b/x11-misc/lxmed/lxmed-20110717.ebuild
index 45eb0639940a..314139cc3375 100644
--- a/x11-misc/lxmed/lxmed-20110717.ebuild
+++ b/x11-misc/lxmed/lxmed-20110717.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lxmed/lxmed-20110717.ebuild,v 1.1 2011/10/22 05:50:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lxmed/lxmed-20110717.ebuild,v 1.2 2011/10/22 05:58:35 ssuominen Exp $
EAPI=4
inherit eutils java-utils-2
@@ -18,14 +18,14 @@ RDEPEND="virtual/jre
x11-libs/gksu"
DEPEND=""
-S=${WORKDIR}/${PN}
+S=${WORKDIR}/${PN}/content
src_prepare() {
- sed -i -e '/^Icon/s:=.*:=lxmed:' content/lxmed.desktop || die
+ sed -i -e '/^Icon/s:=.*:=lxmed:' lxmed.desktop || die
}
src_install() {
- java-pkg_dojar content/LXMenuEditor.jar
+ java-pkg_dojar LXMenuEditor.jar
cat <<-EOF > "${T}"/lxmed
#!/bin/bash
@@ -34,6 +34,6 @@ src_install() {
dobin "${T}"/lxmed
- doicon content/lxmed.png
- domenu content/lxmed.desktop
+ doicon lxmed.png
+ domenu lxmed.desktop
}