summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-06 16:33:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-06 16:33:16 +0000
commit681d88af6f03aa2a555593eeda4189934f3651a0 (patch)
treed009a5fd5dfeb69de96def6dd2669d7066f255c5 /x11-misc/lxmed/lxmed-20120515.ebuild
parentPrune patch from cvs Id line so it actually applies (diff)
downloadgentoo-2-681d88af6f03aa2a555593eeda4189934f3651a0.tar.gz
gentoo-2-681d88af6f03aa2a555593eeda4189934f3651a0.tar.bz2
gentoo-2-681d88af6f03aa2a555593eeda4189934f3651a0.zip
Version bump wrt #416271 by "df"
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/lxmed/lxmed-20120515.ebuild')
-rw-r--r--x11-misc/lxmed/lxmed-20120515.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/lxmed/lxmed-20120515.ebuild b/x11-misc/lxmed/lxmed-20120515.ebuild
new file mode 100644
index 000000000000..ec97da92631d
--- /dev/null
+++ b/x11-misc/lxmed/lxmed-20120515.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lxmed/lxmed-20120515.ebuild,v 1.1 2012/06/06 16:33:16 ssuominen Exp $
+
+EAPI=4
+inherit eutils gnome2-utils java-utils-2
+
+DESCRIPTION="freedesktop.org specification compatible menu editor"
+HOMEPAGE="http://lxmed.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5
+ x11-libs/gksu"
+DEPEND=""
+
+S=${WORKDIR}/${PN}/content
+
+src_prepare() {
+ sed -i -e '/^Icon/s:=.*:=lxmed:' lxmed.desktop || die
+}
+
+src_install() {
+ java-pkg_dojar LXMenuEditor.jar
+ java-pkg_dolauncher lxmed --jar LXMenuEditor.jar
+
+ insinto /usr/share/icons/hicolor/48x48/apps
+ doins lxmed.png
+
+ domenu lxmed.desktop
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }