summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-19 19:49:33 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-19 19:49:33 +0000
commit3a20766e2b6c230e8717db19268ec763242dd21b (patch)
tree190db30686536dc96620cdf060731c311242d51f /x11-misc/keytouch
parentx86 stable wrt security #183567 (diff)
downloadgentoo-2-3a20766e2b6c230e8717db19268ec763242dd21b.tar.gz
gentoo-2-3a20766e2b6c230e8717db19268ec763242dd21b.tar.bz2
gentoo-2-3a20766e2b6c230e8717db19268ec763242dd21b.zip
Version bump
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'x11-misc/keytouch')
-rw-r--r--x11-misc/keytouch/ChangeLog7
-rw-r--r--x11-misc/keytouch/files/digest-keytouch-2.3.13
-rw-r--r--x11-misc/keytouch/keytouch-2.3.1.ebuild90
3 files changed, 99 insertions, 1 deletions
diff --git a/x11-misc/keytouch/ChangeLog b/x11-misc/keytouch/ChangeLog
index 96d36be64291..38ef4f39ee85 100644
--- a/x11-misc/keytouch/ChangeLog
+++ b/x11-misc/keytouch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/keytouch
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/ChangeLog,v 1.7 2007/04/17 14:14:47 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/ChangeLog,v 1.8 2007/07/19 19:49:33 nyhm Exp $
+
+*keytouch-2.3.1 (19 Jul 2007)
+
+ 19 Jul 2007; Tristan Heaven <nyhm@gentoo.org> +keytouch-2.3.1.ebuild:
+ Version bump
17 Apr 2007; Christian Faulhammer <opfer@gentoo.org>
keytouch-2.2.4.ebuild:
diff --git a/x11-misc/keytouch/files/digest-keytouch-2.3.1 b/x11-misc/keytouch/files/digest-keytouch-2.3.1
new file mode 100644
index 000000000000..fabaee004b16
--- /dev/null
+++ b/x11-misc/keytouch/files/digest-keytouch-2.3.1
@@ -0,0 +1,3 @@
+MD5 592748a1914bbcc30afe5c68293349b2 keytouch-2.3.1.tar.gz 806780
+RMD160 8df52788269d298f3fa1beb7d9315cda0d6391e2 keytouch-2.3.1.tar.gz 806780
+SHA256 d3b9c6a203e7016e98821ca16d35723570e7125c609e8f033c39e5a5719e5721 keytouch-2.3.1.tar.gz 806780
diff --git a/x11-misc/keytouch/keytouch-2.3.1.ebuild b/x11-misc/keytouch/keytouch-2.3.1.ebuild
new file mode 100644
index 000000000000..de0cf2253151
--- /dev/null
+++ b/x11-misc/keytouch/keytouch-2.3.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/keytouch/keytouch-2.3.1.ebuild,v 1.1 2007/07/19 19:49:33 nyhm Exp $
+
+inherit eutils versionator linux-info
+
+DESCRIPTION="Easily configure extra keyboard function keys"
+HOMEPAGE="http://keytouch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acpi kde"
+
+RDEPEND=">=x11-libs/gtk+-2
+ gnome-base/gnome-menus
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ acpi? ( sys-power/acpid )
+ kde? ( || (
+ kde-base/kdesu
+ kde-base/kdebase ) )
+ !kde? ( x11-libs/gksu )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i 's/install-data-local//1' \
+ keytouch{-acpid,d,-init}/Makefile.in \
+ || die "sed failed"
+
+ sed -i 's/gnome-calculator/gcalctool/' \
+ keyboards/* || die "sed failed"
+}
+
+src_compile() {
+ local d
+ for d in . keytouch-config keytouch-keyboard ; do
+ cd "${S}"/${d}
+ econf || die
+ emake || die "emake ${d} failed"
+ done
+}
+
+src_install() {
+ if use acpi ; then
+ newinitd "${FILESDIR}"/${PN}-acpid ${PN} || die "newinitd failed"
+ else
+ doinitd "${FILESDIR}"/${PN} || die "doinitd failed"
+ fi
+
+ newicon keytouch-keyboard/pixmaps/icon.png ${PN}.png
+ make_desktop_entry ${PN} keyTouch ${PN}.png System
+
+ dodoc AUTHORS ChangeLog
+
+ local d
+ for d in . keytouch-config keytouch-keyboard ; do
+ emake -C ${d} DESTDIR="${D}" install \
+ || die "emake install ${d} failed"
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "To use keyTouch, add \"keytouchd\" to your"
+ elog "X startup programs and run"
+ elog "\"rc-update add keytouch default\""
+ elog
+ elog "If support for your keyboard is not included in"
+ elog "this release, check for new keyboard files at"
+ elog "${HOMEPAGE}dl-keyboards.html"
+ elog
+ elog "x11-misc/keytouch-editor can be used to create"
+ elog "your own keyboard files"
+ echo
+ if use acpi && ! linux_chkconfig_present INPUT_EVDEV ; then
+ ewarn "To add support for ACPI hotkeys, CONFIG_INPUT_EVDEV"
+ ewarn "must be enabled in your kernel config."
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " <*>/<M> Event interface"
+ echo
+ fi
+}