summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2012-12-27 06:10:52 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2012-12-27 06:10:52 +0000
commitbfb36e0dd8a28174c5883c1ee478c0e1a091f057 (patch)
treebaebfe256e3cc3cec01903211b94039dff9b8b6c /x11-misc/kbdd
parentMask tracker[eds] since gnome-3.6 has been unmasked (bug #436460). (diff)
downloadgentoo-2-bfb36e0dd8a28174c5883c1ee478c0e1a091f057.tar.gz
gentoo-2-bfb36e0dd8a28174c5883c1ee478c0e1a091f057.tar.bz2
gentoo-2-bfb36e0dd8a28174c5883c1ee478c0e1a091f057.zip
fix build bug #448720
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-misc/kbdd')
-rw-r--r--x11-misc/kbdd/ChangeLog4
-rw-r--r--x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch16
-rw-r--r--x11-misc/kbdd/kbdd-0.7.ebuild5
3 files changed, 23 insertions, 2 deletions
diff --git a/x11-misc/kbdd/ChangeLog b/x11-misc/kbdd/ChangeLog
index 8b137891791f..536a539a04d4 100644
--- a/x11-misc/kbdd/ChangeLog
+++ b/x11-misc/kbdd/ChangeLog
@@ -1 +1,5 @@
+ 27 Dec 2012; <qnikst@gentoo.org> +files/kbdd-0.7-fix-non-dbus-build.patch,
+ kbdd-0.7.ebuild:
+ fix build bug #448720
+
diff --git a/x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch b/x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch
new file mode 100644
index 000000000000..4bb3bb7feeca
--- /dev/null
+++ b/x11-misc/kbdd/files/kbdd-0.7-fix-non-dbus-build.patch
@@ -0,0 +1,16 @@
+diff --git a/src/kbdd.c b/src/kbdd.c
+index 45968be..9402725 100644
+--- a/src/kbdd.c
++++ b/src/kbdd.c
+@@ -31,9 +31,10 @@
+ #include "config.h"
+ #endif
+
++#include <glib.h>
++
+ #ifdef ENABLE_DBUS
+ #include <pthread.h>
+-#include <glib.h>
+ #include "dbus/m-kbdd-service.h"
+ #include "dbus/kbdd-service-glue.h"
+ #endif
diff --git a/x11-misc/kbdd/kbdd-0.7.ebuild b/x11-misc/kbdd/kbdd-0.7.ebuild
index a0024ec58557..60db8f17bbd5 100644
--- a/x11-misc/kbdd/kbdd-0.7.ebuild
+++ b/x11-misc/kbdd/kbdd-0.7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/kbdd/kbdd-0.7.ebuild,v 1.1 2012/12/21 10:19:36 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/kbdd/kbdd-0.7.ebuild,v 1.2 2012/12/27 06:10:52 qnikst Exp $
EAPI=4
-inherit autotools
+inherit autotools eutils
DESCRIPTION="Very simple layout switcher"
HOMEPAGE="http://github.com/qnikst/kbdd"
@@ -27,6 +27,7 @@ S="${WORKDIR}"
src_prepare() {
cd "${WORKDIR}"/qnikst-kbdd-*
+ epatch "${FILESDIR}"/kbdd-0.7-fix-non-dbus-build.patch
S=$(pwd)
eautoreconf
}