summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-07-22 09:41:18 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-07-22 09:41:18 +0000
commitb69350941911d340670fb1f2bc5cb926626ec1db (patch)
tree00f9ba767c9b35d020a092b725e9ecb3d2a59490 /x11-misc/i3lock
parentProvide ruby_implementations_depend() to facilitate ebuilds with RUBY_OPTIONA... (diff)
downloadgentoo-2-b69350941911d340670fb1f2bc5cb926626ec1db.tar.gz
gentoo-2-b69350941911d340670fb1f2bc5cb926626ec1db.tar.bz2
gentoo-2-b69350941911d340670fb1f2bc5cb926626ec1db.zip
Initial import. Ebuild written by me
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/i3lock')
-rw-r--r--x11-misc/i3lock/ChangeLog10
-rw-r--r--x11-misc/i3lock/files/i3lock-2.1-makefile.patch52
-rw-r--r--x11-misc/i3lock/i3lock-2.1.ebuild36
-rw-r--r--x11-misc/i3lock/metadata.xml9
4 files changed, 107 insertions, 0 deletions
diff --git a/x11-misc/i3lock/ChangeLog b/x11-misc/i3lock/ChangeLog
new file mode 100644
index 000000000000..4cc6cd71110d
--- /dev/null
+++ b/x11-misc/i3lock/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/i3lock
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3lock/ChangeLog,v 1.1 2011/07/22 09:41:18 xarthisius Exp $
+
+*i3lock-2.1 (22 Jul 2011)
+
+ 22 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> +i3lock-2.1.ebuild,
+ +files/i3lock-2.1-makefile.patch, +metadata.xml:
+ Initial import. Ebuild written by me
+
diff --git a/x11-misc/i3lock/files/i3lock-2.1-makefile.patch b/x11-misc/i3lock/files/i3lock-2.1-makefile.patch
new file mode 100644
index 000000000000..a560c2d3d3fe
--- /dev/null
+++ b/x11-misc/i3lock/files/i3lock-2.1-makefile.patch
@@ -0,0 +1,52 @@
+--- a/Makefile
++++ b/Makefile
+@@ -10,30 +10,30 @@
+ CFLAGS += -std=c99
+ CFLAGS += -pipe
+ CFLAGS += -Wall
+-CFLAGS += -D_GNU_SOURCE
++CPPFLAGS += -D_GNU_SOURCE
+ ifndef NOLIBCAIRO
+ CFLAGS += $(shell pkg-config --cflags cairo xcb-keysyms xcb-dpms)
+-LDFLAGS += $(shell pkg-config --libs cairo xcb-keysyms xcb-dpms xcb-image)
++LIBS += $(shell pkg-config --libs cairo xcb-keysyms xcb-dpms xcb-image)
+ else
+ CFLAGS += -DNOLIBCAIRO
+ CFLAGS += $(shell pkg-config --cflags xcb-keysyms xcb-dpms)
+-LDFLAGS += $(shell pkg-config --libs xcb-keysyms xcb-dpms xcb-image)
++LIBS += $(shell pkg-config --libs xcb-keysyms xcb-dpms xcb-image)
+ endif
+-LDFLAGS += -lpam
++LIBS += -lpam
+
+ FILES:=$(wildcard *.c)
+ FILES:=$(FILES:.c=.o)
+
+ VERSION:=2.1
+ GIT_VERSION:="2.1 (2011-03-13)"
+-CFLAGS += -DVERSION=\"${GIT_VERSION}\"
++CPPFLAGS += -DVERSION=\"${GIT_VERSION}\"
+
+ .PHONY: install clean uninstall
+
+ all: i3lock
+
+ i3lock: ${FILES}
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ clean:
+ rm -f i3lock ${FILES} i3lock-${VERSION}.tar.gz
+@@ -41,8 +41,12 @@
+ install: all
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL) -d $(DESTDIR)$(SYSCONFDIR)/pam.d
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/man/man1
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/doc/i3lock-${VERSION}
+ $(INSTALL) -m 755 i3lock $(DESTDIR)$(PREFIX)/bin/i3lock
+ $(INSTALL) -m 644 i3lock.pam $(DESTDIR)$(SYSCONFDIR)/pam.d/i3lock
++ $(INSTALL) -m 644 i3lock.1 $(DESTDIR)$(PREFIX)/share/man/man1
++ $(INSTALL) -m 644 README $(DESTDIR)$(PREFIX)/share/doc/i3lock-${VERSION}
+
+ uninstall:
+ rm -f $(DESTDIR)$(PREFIX)/bin/i3lock
diff --git a/x11-misc/i3lock/i3lock-2.1.ebuild b/x11-misc/i3lock/i3lock-2.1.ebuild
new file mode 100644
index 000000000000..326f12068be8
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3lock/i3lock-2.1.ebuild,v 1.1 2011/07/22 09:41:18 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="http://i3wm.org/i3lock/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cairo"
+
+RDEPEND="virtual/pam
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-image
+ cairo? ( x11-libs/cairo[xcb] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+}
+
+src_configure() {
+ use cairo || export NOLIBCAIRO=1
+}
diff --git a/x11-misc/i3lock/metadata.xml b/x11-misc/i3lock/metadata.xml
new file mode 100644
index 000000000000..b5caab41c7b2
--- /dev/null
+++ b/x11-misc/i3lock/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+</pkgmetadata>