summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-11 23:05:34 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-11 23:05:34 +0000
commit62bd7a7dc8ca3a0a778b599faf8b6608bf4c867a (patch)
treebc1931e7903076548e2e725e1129f20e063b4200 /x11-misc/hotkeys
parentQA: Removed default src_compile (diff)
downloadgentoo-2-62bd7a7dc8ca3a0a778b599faf8b6608bf4c867a.tar.gz
gentoo-2-62bd7a7dc8ca3a0a778b599faf8b6608bf4c867a.tar.bz2
gentoo-2-62bd7a7dc8ca3a0a778b599faf8b6608bf4c867a.zip
QA: Use use_with for econf.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc/hotkeys')
-rw-r--r--x11-misc/hotkeys/ChangeLog5
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild29
2 files changed, 14 insertions, 20 deletions
diff --git a/x11-misc/hotkeys/ChangeLog b/x11-misc/hotkeys/ChangeLog
index a08a346eccb9..8eafb1d019bd 100644
--- a/x11-misc/hotkeys/ChangeLog
+++ b/x11-misc/hotkeys/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/hotkeys
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.22 2005/06/25 15:29:14 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.23 2005/07/11 23:05:34 swegener Exp $
+
+ 11 Jul 2005; Sven Wegener <swegener@gentoo.org> hotkeys-0.5.7.1-r1.ebuild:
+ QA: Use use_with for econf.
25 Jun 2005; Olivier Crête <tester@gentoo.org> hotkeys-0.5.7.1-r1.ebuild:
Stable on amd64
diff --git a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
index 6ae64be12a00..9e8ff578e27b 100644
--- a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
+++ b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.10 2005/06/25 15:29:14 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.11 2005/07/11 23:05:34 swegener Exp $
inherit eutils
@@ -20,30 +20,21 @@ DEPEND="X? ( virtual/x11 )
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PF}-gentoo.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/${PF}-gentoo.diff
}
src_compile() {
-
- use X \
- && myconf="${myconf} --with-X" \
- || myconf="${myconf} --without-X"
-
- use xosd \
- && myconf="${myconf} --with-xosd" \
- || myconf="${myconf} --without-xosd"
-
- use gtk \
- && myconf="${myconf} --with-gtk" \
- || myconf="${myconf} --without-gtk"
-
- econf ${myconf} --disable-db3test || die "./configure failed"
-
+ econf \
+ --disable-db3test \
+ $(use_with X) \
+ $(use_with xosd) \
+ $(use_with gtk) \
+ || die "./configure failed"
emake || die
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS BUGS ChangeLog COPYING README TODO
}