summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-08-27 22:50:52 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-08-27 22:50:52 +0000
commit3f64fce499e3952e58df8034a8e4bf58440deba7 (patch)
treec14e77e3ac76d18eecef85209f529d58248d3094 /x11-misc/hotkeys
parentinitial import (diff)
downloadgentoo-2-3f64fce499e3952e58df8034a8e4bf58440deba7.tar.gz
gentoo-2-3f64fce499e3952e58df8034a8e4bf58440deba7.tar.bz2
gentoo-2-3f64fce499e3952e58df8034a8e4bf58440deba7.zip
db-4 compile fix
Diffstat (limited to 'x11-misc/hotkeys')
-rw-r--r--x11-misc/hotkeys/ChangeLog6
-rw-r--r--x11-misc/hotkeys/Manifest6
-rw-r--r--x11-misc/hotkeys/files/hotkeys-0.5.7.1-r1-gentoo.diff34
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild10
4 files changed, 47 insertions, 9 deletions
diff --git a/x11-misc/hotkeys/ChangeLog b/x11-misc/hotkeys/ChangeLog
index 8b69b1e4f81b..9568313408ce 100644
--- a/x11-misc/hotkeys/ChangeLog
+++ b/x11-misc/hotkeys/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/hotkeys
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.12 2003/08/15 11:25:28 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.13 2003/08/27 22:50:46 lanius Exp $
+
+ 28 Aug 2003; Heinrich Wendel <lanius@gentoo.org> hotkeys-0.5.7.1-r1.ebuild,
+ files/hotkeys-0.5.7.1-r1-gentoo.diff:
+ fixed compile with db-4 installed, thx to Thomas Bjorn Andersen <tba@gen-v.net>
15 Aug 2003; Heinrich Wendel <lanius@gentoo.org> hotkeys-0.5.4.ebuild,
hotkeys-0.5.5.ebuild, metadata.xml, files/hotkeys-0.5.4-gentoo.diff.gz,
diff --git a/x11-misc/hotkeys/Manifest b/x11-misc/hotkeys/Manifest
index c54714633699..301323237427 100644
--- a/x11-misc/hotkeys/Manifest
+++ b/x11-misc/hotkeys/Manifest
@@ -1,8 +1,8 @@
-MD5 323f7786418bc9e63316328fe1d8300c hotkeys-0.5.7.1-r1.ebuild 1158
-MD5 102e1ea97aa07518dac23932d8eed040 ChangeLog 1670
+MD5 52a624e40db21b3d984417fe5f88d606 hotkeys-0.5.7.1-r1.ebuild 1160
+MD5 0fd8464ee1e2c102642ad50e40d64145 ChangeLog 1871
MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
MD5 718a70fb145ea461d426a7d663194f8b hotkeys-0.5.7.1.ebuild 963
-MD5 271ec5a699afabc5f0376bb5a9be4fe7 files/hotkeys-0.5.7.1-r1-gentoo.diff 325
+MD5 2b1987adcf943427133e4f897782604c files/hotkeys-0.5.7.1-r1-gentoo.diff 1379
MD5 26aa28d3165265b8153adbb4a071d0af files/digest-hotkeys-0.5.7.1-r1 67
MD5 26aa28d3165265b8153adbb4a071d0af files/digest-hotkeys-0.5.7.1 67
MD5 ceb23c573710586557d5f664975c6740 files/hotkeys-0.5.7.1-gentoo.diff 538
diff --git a/x11-misc/hotkeys/files/hotkeys-0.5.7.1-r1-gentoo.diff b/x11-misc/hotkeys/files/hotkeys-0.5.7.1-r1-gentoo.diff
index b76c8dd9822b..06092cc88134 100644
--- a/x11-misc/hotkeys/files/hotkeys-0.5.7.1-r1-gentoo.diff
+++ b/x11-misc/hotkeys/files/hotkeys-0.5.7.1-r1-gentoo.diff
@@ -11,3 +11,37 @@
#include "hotkeys.h"
#include "kbddef.h"
+
+--- src/Makefile.in 2002-12-08 15:34:44.000000000 +0100
++++ src/Makefile.in 2003-08-27 22:36:18.000000000 +0200
+@@ -102,7 +102,7 @@
+ man_MANS = hotkeys.1
+
+ CFLAGS = @CFLAGS@ @X_CFLAGS@ @XML_CFLAGS@ @LIBXOSD_CFLAGS@ @GTK_CFLAGS@ -I.. # -DDEBUG
+-LIBS = @LIBS@ @X_LIBS@ @XML_LIBS@ @LIBXOSD_LIBS@ @GTK_LIBS@
++LIBS = @LIBS@ @X_LIBS@ @XML_LIBS@ @LIBXOSD_LIBS@ @GTK_LIBS@ @libdir@/libdb.so.3
+ DEFS = @DEFS@ -DSHAREDIR=\"@datadir@/@PACKAGE@\" -DCONFDIR=\"@sysconfdir@\" -DCONFIG_NAME=\"@PACKAGE@.conf\"
+
+
+--- src/conf.c 2002-11-27 20:30:08.000000000 +0100
++++ src/conf.c 2003-08-27 22:19:14.000000000 +0200
+@@ -25,7 +25,7 @@
+ #include "common.h"
+
+ #include <stdio.h>
+-#include <db.h>
++#include <db3/db.h>
+ #include <string.h>
+ #include <sys/param.h>
+
+--- src/hotkeys.c 2002-12-03 20:26:32.000000000 +0100
++++ src/hotkeys.c 2003-08-27 22:19:31.000000000 +0200
+@@ -37,7 +37,7 @@
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <stdarg.h>
+-#include <db.h>
++#include <db3/db.h>
+ #include <errno.h>
+ #ifdef HAVE_GETOPT_LONG
+ #include <getopt.h>
diff --git a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
index e33db07bc504..9116226e51fa 100644
--- a/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
+++ b/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.1 2003/08/15 11:25:28 lanius Exp $
+# Copyright 1999-2003 Gentoo Technologies, Inc. Distributed under the terms of
+# the GNU General Public License v2 $Header:
+# /home/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.7.1-r1.ebuild,v 1.1
+# 2003/08/15 11:25:28 lanius Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Make use of extra buttons on newer keyboards."
@@ -14,7 +15,6 @@ KEYWORDS="~x86 ~sparc"
DEPEND="X? ( virtual/x11 )
>=dev-libs/libxml2-2.2.8
=sys-libs/db-3.2*
- !>=sys-libs/db-4*
xosd? ( >=x11-libs/xosd-1.0.0 )
gtk2? ( >=x11-libs/gtk+-2.0.0 )"
@@ -38,7 +38,7 @@ src_compile() {
&& myconf="${myconf} --with-gtk" \
|| myconf="${myconf} --without-gtk"
- econf ${myconf} || die "./configure failed"
+ econf ${myconf} --disable-db3test || die "./configure failed"
emake || die
}