summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-09-11 19:06:31 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-09-11 19:06:31 +0000
commit02a165e3683cb5005101cfceb0716df75daf6326 (patch)
tree78e07e9b14bfd306f0efaf1f606f64c0f641f3a6 /x11-misc/hotkeys
parentMasked hotkeys-0.5.5 (diff)
downloadgentoo-2-02a165e3683cb5005101cfceb0716df75daf6326.tar.gz
gentoo-2-02a165e3683cb5005101cfceb0716df75daf6326.tar.bz2
gentoo-2-02a165e3683cb5005101cfceb0716df75daf6326.zip
Version bump, should close #6687
Diffstat (limited to 'x11-misc/hotkeys')
-rw-r--r--x11-misc/hotkeys/ChangeLog7
-rw-r--r--x11-misc/hotkeys/files/digest-hotkeys-0.5.51
-rw-r--r--x11-misc/hotkeys/files/hotkeys-0.5.5-gentoo.diff77
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.4.ebuild6
-rw-r--r--x11-misc/hotkeys/hotkeys-0.5.5.ebuild43
5 files changed, 131 insertions, 3 deletions
diff --git a/x11-misc/hotkeys/ChangeLog b/x11-misc/hotkeys/ChangeLog
index 78819c11553e..c945928e792b 100644
--- a/x11-misc/hotkeys/ChangeLog
+++ b/x11-misc/hotkeys/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/hotkeys
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.1 2002/06/11 23:31:02 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/ChangeLog,v 1.2 2002/09/11 19:06:31 aliz Exp $
+
+*hotkeys-0.5.5.ebuild (11 Sep 2002)
+
+ 11 Sep 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Unoffical version bump to 0.5.5. Should close #6687.
*hotkeys-0.5.4.ebuild (11 Jun 2002)
diff --git a/x11-misc/hotkeys/files/digest-hotkeys-0.5.5 b/x11-misc/hotkeys/files/digest-hotkeys-0.5.5
new file mode 100644
index 000000000000..8460aa1b35da
--- /dev/null
+++ b/x11-misc/hotkeys/files/digest-hotkeys-0.5.5
@@ -0,0 +1 @@
+MD5 2b46502efec8f2dad776b473482b4368 hotkeys-0.5.5.tar.bz2 342193
diff --git a/x11-misc/hotkeys/files/hotkeys-0.5.5-gentoo.diff b/x11-misc/hotkeys/files/hotkeys-0.5.5-gentoo.diff
new file mode 100644
index 000000000000..d65f92424e96
--- /dev/null
+++ b/x11-misc/hotkeys/files/hotkeys-0.5.5-gentoo.diff
@@ -0,0 +1,77 @@
+--- ./src/kbddef.c.xml2 Sun Jun 2 22:37:33 2002
++++ ./src/kbddef.c Sun Jun 2 22:37:43 2002
+@@ -38,7 +38,7 @@
+ #include "XF86keysym.h"
+
+ #include <xmlmemory.h>
+-#include <parser.h>
++#include <libxml2/libxml/parser.h>
+
+ #include "hotkeys.h"
+ #include "kbddef.h"
+--- ./configure.xml2 Mon Oct 29 12:47:31 2001
++++ ./configure Sun Jun 2 22:37:17 2002
+@@ -2189,14 +2189,14 @@
+ CFLAGS="$CFLAGS $XML_CFLAGS"
+ LIBS="$LIBS $XML_LIBS"
+
+- echo $ac_n "checking for xmlParseFile in -lxml""... $ac_c" 1>&6
+-echo "configure:2194: checking for xmlParseFile in -lxml" >&5
++ echo $ac_n "checking for xmlParseFile in -lxml2""... $ac_c" 1>&6
++echo "configure:2194: checking for xmlParseFile in -lxml22" >&5
+ ac_lib_var=`echo xml'_'xmlParseFile | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lxml $LIBS"
++LIBS="-lxml2 $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2202 "configure"
+ #include "confdefs.h"
+@@ -2230,7 +2230,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lxml $LIBS"
++ LIBS="-lxml2 $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -2247,7 +2247,7 @@
+ #line 2248 "configure"
+ #include "confdefs.h"
+
+- #include <parser.h>
++ #include <libxml2/libxml/parser.h>
+ int main ()
+ {
+ #ifdef xmlChildrenNode
+
+--- /tmp/kbddef.c Wed Sep 11 18:51:19 2002
++++ src/kbddef.c Wed Sep 11 18:51:33 2002
+@@ -37,7 +37,7 @@
+ */
+ #include "XF86keysym.h"
+
+-#include <xmlmemory.h>
++#include <libxml2/libxml/xmlmemory.h>
+ #include <libxml2/libxml/parser.h>
+
+ #include "hotkeys.h"
+
+--- /tmp/configure Wed Sep 11 19:02:34 2002
++++ configure Wed Sep 11 19:03:12 2002
+@@ -2447,10 +2447,10 @@
+
+
+ if test ! x$xosd_libdir = x; then
+- LIBS="$LIBS -L$xosd_libdir"
++ LIBS="-L$xosd_libdir $LIBS"
+ fi
+ if test ! x$xosd_incdir = x; then
+- CPPFLAGS="$CPPFLAGS -I$xosd_incdir"
++ CPPFLAGS="-I$xosd_incdir $CPPFLAGS"
+ fi
+
+ if test "x$enable_xosd" = "xyes"
diff --git a/x11-misc/hotkeys/hotkeys-0.5.4.ebuild b/x11-misc/hotkeys/hotkeys-0.5.4.ebuild
index 152725e03e8d..f39be2ecfa41 100644
--- a/x11-misc/hotkeys/hotkeys-0.5.4.ebuild
+++ b/x11-misc/hotkeys/hotkeys-0.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.4.ebuild,v 1.4 2002/08/14 23:44:15 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.4.ebuild,v 1.5 2002/09/11 19:06:31 aliz Exp $
NAME="hotkeys"
S=${WORKDIR}/${P}
@@ -16,7 +16,7 @@ DEPEND="virtual/x11
virtual/glibc
dev-libs/libxml2
>=sys-libs/db-3.2.3
- x11-libs/xosd"
+ =x11-libs/xosd-0.7.0"
RDEPEND="${DEPEND}"
@@ -30,6 +30,8 @@ src_compile() {
./configure --host=${CHOST} \
--prefix=/usr \
--mandir=/usr/share/man \
+ --libdir=/usr/lib/xosd-0.7.0 \
+ --includedir=/usr/include/xosd-0.7.0 \
--sysconfdir=/etc || die "./configure failed"
emake || die
}
diff --git a/x11-misc/hotkeys/hotkeys-0.5.5.ebuild b/x11-misc/hotkeys/hotkeys-0.5.5.ebuild
new file mode 100644
index 000000000000..014911c3cac0
--- /dev/null
+++ b/x11-misc/hotkeys/hotkeys-0.5.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/hotkeys/hotkeys-0.5.5.ebuild,v 1.1 2002/09/11 19:06:31 aliz Exp $
+
+NAME="hotkeys"
+S=${WORKDIR}/${P}
+DESCRIPTION="Make use of extra buttons on newer keyboards."
+SRC_URI="http://ypwong.org/hotkeys/${P}.tar.bz2"
+HOMEPAGE="http://ypwong.org/hotkeys/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/x11
+ virtual/glibc
+ dev-libs/libxml2
+ >=sys-libs/db-3.2.3
+ =x11-libs/xosd-0.7.0"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-xosd-lib=/usr/lib/xosd-0.7.0 \
+ --with-xosd-inc=/usr/include/xosd-0.7.0 \
+ --sysconfdir=/etc || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING README TODO
+}
+