summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-02-16 17:50:15 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-02-16 17:50:15 +0000
commit7560af8837a22c473edabb23761c58f93c6c6c32 (patch)
tree4d2ee95003bbcfd546c52644caec4126817b920f /x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild
parentRemove old. (diff)
downloadgentoo-2-7560af8837a22c473edabb23761c58f93c6c6c32.tar.gz
gentoo-2-7560af8837a22c473edabb23761c58f93c6c6c32.tar.bz2
gentoo-2-7560af8837a22c473edabb23761c58f93c6c6c32.zip
Took maintainership. Version bump to 0.6.7; not 0.6.9 since that archive misses files and thus doesn't compile, 0.7.0 can be obtained through the live ebuild I have added, although it does not compile currently due to https://github.com/mattn/growl-for-linux/commit/9950a92838f0d5755eba850f7681bbb44c19dae1. Thanks to df for reporting, thanks to pinkbyte for improving the ebuild. Fixes bug #413337.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild')
-rw-r--r--x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild b/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild
new file mode 100644
index 000000000000..54eb704cddf2
--- /dev/null
+++ b/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/growl-for-linux/growl-for-linux-0.6.7.ebuild,v 1.1 2013/02/16 17:50:15 tomwij Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="Growl Implementation For Linux"
+HOMEPAGE="http://mattn.github.com/growl-for-linux/"
+SRC_URI="mirror://github/mattn/growl-for-linux/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-misc/curl
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ local myeconfargs=(
+ LIBS=-lgthread-2.0
+ --disable-static
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --modules
+}