summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephanie J. Lockwood-Childs <wormo@gentoo.org>2008-08-09 18:06:31 +0000
committerStephanie J. Lockwood-Childs <wormo@gentoo.org>2008-08-09 18:06:31 +0000
commitb754ad1bad8504fd0837770b107993ee59b3787c (patch)
tree48413de576728ecf901cb7e9302006935c3adf32 /x11-misc/googleearth
parentamd64 stable wrt bug #233123 (diff)
downloadgentoo-2-b754ad1bad8504fd0837770b107993ee59b3787c.tar.gz
gentoo-2-b754ad1bad8504fd0837770b107993ee59b3787c.tar.bz2
gentoo-2-b754ad1bad8504fd0837770b107993ee59b3787c.zip
Bring back stable version 4.2.205.5730, made possible by versioned SRC_URI discovered by Daniel Wallace (bug #221105)
(Portage version: 2.1.4.4, RepoMan options: --force)
Diffstat (limited to 'x11-misc/googleearth')
-rw-r--r--x11-misc/googleearth/ChangeLog9
-rw-r--r--x11-misc/googleearth/googleearth-4.2.205.5730.ebuild80
-rw-r--r--x11-misc/googleearth/googleearth-4.3.7284.3916.ebuild4
3 files changed, 90 insertions, 3 deletions
diff --git a/x11-misc/googleearth/ChangeLog b/x11-misc/googleearth/ChangeLog
index 35704e112a4e..81706bb9b84d 100644
--- a/x11-misc/googleearth/ChangeLog
+++ b/x11-misc/googleearth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/googleearth
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.38 2008/08/09 07:45:55 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.39 2008/08/09 18:06:31 wormo Exp $
+
+*googleearth-4.2.205.5730 (10 Aug 2008)
+
+ 10 Aug 2008; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ +googleearth-4.2.205.5730.ebuild, googleearth-4.3.7284.3916.ebuild:
+ Introduce partially revisioned SRC_URI recommended by Daniel Wallace
+ in bug #221105, so now 4.2 ebuild can be available in parallel with 4.3
09 Aug 2008; Stephanie Lockwood-Childs <wormo@gentoo.org>
googleearth-4.3.7284.3916.ebuild:
diff --git a/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild b/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild
new file mode 100644
index 000000000000..18231ecbbba9
--- /dev/null
+++ b/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild,v 1.5 2008/08/09 18:06:31 wormo Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+SRC_URI="http://dl.google.com/earth/client/GE4/release_4_2/GoogleEarthLinux.bin"
+
+LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror strip"
+IUSE=""
+
+RDEPEND="x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-baselibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ <x11-drivers/ati-drivers-8.28.8 ) )
+ media-fonts/ttf-bitstream-vera"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_makeself
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" postinstall.sh
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml
+ domenu Google-${PN}.desktop
+ doicon ${PN}-icon.png
+ dodoc README.linux
+
+ cd bin
+ tar xf "${WORKDIR}"/${PN}-linux-x86.tar
+ exeinto /opt/${PN}
+ doexe *
+
+ cd "${D}"/opt/${PN}
+ tar xf "${WORKDIR}"/${PN}-data.tar
+
+ cd "${D}"
+ # mime magic for gnome by Ed Catmur in bug 141371
+ epatch "${FILESDIR}"/mime-magic.patch
+
+ # make sure we install with correct permissions
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/{xml,res{,ources}}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/x11-misc/googleearth/googleearth-4.3.7284.3916.ebuild b/x11-misc/googleearth/googleearth-4.3.7284.3916.ebuild
index 4502882d65e6..0e6ff99db83c 100644
--- a/x11-misc/googleearth/googleearth-4.3.7284.3916.ebuild
+++ b/x11-misc/googleearth/googleearth-4.3.7284.3916.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.3.7284.3916.ebuild,v 1.2 2008/08/09 07:45:55 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.3.7284.3916.ebuild,v 1.3 2008/08/09 18:06:31 wormo Exp $
inherit eutils fdo-mime
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="http://earth.google.com/"
-SRC_URI="http://dl.google.com/earth/client/current/GoogleEarthLinux.bin"
+SRC_URI="http://dl.google.com/earth/client/GE4/release_4_3/GoogleEarthLinux.bin"
LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
SLOT="0"