summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-01 13:48:23 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-01 13:48:23 +0000
commitf7f6ed09c90459fb9dfc9b44a97a230bb5d8dd5f (patch)
treecc33983a1cae3ed5e27d9d89cbae38a1539f6dab /x11-misc/ftmenu/ftmenu-0.1.ebuild
parentbump to 1.0.0.1 first non beta release (diff)
downloadgentoo-2-f7f6ed09c90459fb9dfc9b44a97a230bb5d8dd5f.tar.gz
gentoo-2-f7f6ed09c90459fb9dfc9b44a97a230bb5d8dd5f.tar.bz2
gentoo-2-f7f6ed09c90459fb9dfc9b44a97a230bb5d8dd5f.zip
Initial commit; ebuild by me.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'x11-misc/ftmenu/ftmenu-0.1.ebuild')
-rw-r--r--x11-misc/ftmenu/ftmenu-0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/ftmenu/ftmenu-0.1.ebuild b/x11-misc/ftmenu/ftmenu-0.1.ebuild
new file mode 100644
index 000000000000..79382bbfea02
--- /dev/null
+++ b/x11-misc/ftmenu/ftmenu-0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ftmenu/ftmenu-0.1.ebuild,v 1.1 2005/02/01 13:48:23 ka0ttic Exp $
+
+DESCRIPTION="A tray menu for the Fluxbox toolbar"
+HOMEPAGE="http://ftmenu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND="x11-wm/fluxbox
+ >=x11-libs/gtk+-2.6"
+
+
+src_compile() {
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto /usr/share/${PN} ; doins img/fb.xpm
+ dodoc AUTHORS README ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use ftmenu, edit your ~/.fluxbox/menu file and modify the [begin]"
+ einfo "line to contain the path to an icon of your choice."
+ einfo
+ einfo "For example, to use the default ftmenu xpm icon:"
+ einfo " [begin] (Fluxbox-0.9.12) </usr/share/ftmenu/fb.xpm>"
+ einfo
+ einfo "Next, add 'ftmenu &' to your X startup file (~/.xinitrc or ~/.xsession)."
+ echo
+}