summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-06 11:19:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-06 11:19:00 +0000
commit031cd614f750198a9f5e2af79307cd765a0466d6 (patch)
treef4080c5ec05fced72455781a5c91a6505d5c79a5 /x11-misc/fme
parentMore Makefile fixes wrt bug #318353 (diff)
downloadgentoo-2-031cd614f750198a9f5e2af79307cd765a0466d6.tar.gz
gentoo-2-031cd614f750198a9f5e2af79307cd765a0466d6.tar.bz2
gentoo-2-031cd614f750198a9f5e2af79307cd765a0466d6.zip
Fix building with GCC 4.5+ wrt #318409.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/fme')
-rw-r--r--x11-misc/fme/ChangeLog8
-rw-r--r--x11-misc/fme/files/fme-1.1.2-gcc45.patch31
-rw-r--r--x11-misc/fme/fme-1.1.2.ebuild15
3 files changed, 47 insertions, 7 deletions
diff --git a/x11-misc/fme/ChangeLog b/x11-misc/fme/ChangeLog
index 780bbcfa5bbf..a2bcd89b8db2 100644
--- a/x11-misc/fme/ChangeLog
+++ b/x11-misc/fme/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fme
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fme/ChangeLog,v 1.6 2008/09/22 13:04:39 omp Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fme/ChangeLog,v 1.7 2010/05/06 11:18:59 ssuominen Exp $
+
+ 06 May 2010; Samuli Suominen <ssuominen@gentoo.org> fme-1.1.2.ebuild,
+ +files/fme-1.1.2-gcc45.patch:
+ Fix building with GCC 4.5+ wrt #318409.
22 Sep 2008; David Shakaryan <omp@gentoo.org> metadata.xml:
Change herd from commonbox to desktop-wm.
diff --git a/x11-misc/fme/files/fme-1.1.2-gcc45.patch b/x11-misc/fme/files/fme-1.1.2-gcc45.patch
new file mode 100644
index 000000000000..6c554a43a643
--- /dev/null
+++ b/x11-misc/fme/files/fme-1.1.2-gcc45.patch
@@ -0,0 +1,31 @@
+http://bugs.gentoo.org/318409
+
+--- src/ui.cc
++++ src/ui.cc
+@@ -886,7 +886,7 @@
+ unsigned i=1;
+ for ( Glib::Container_Helpers::ArrayHandleIterator<Glib::Container_Helpers::TypeTraits<Glib::ustring> > iter=dirs.begin(); iter!=dirs.end(); iter++ ) {
+ try {
+- Glib::Dir::Dir directory(*iter);
++ Glib::Dir directory(*iter);
+ #else
+ boost::regex re("\\:");
+ boost::sregex_token_iterator dir(path.begin(), path.end(), re, -1);
+@@ -894,7 +894,7 @@
+
+ for ( unsigned i=1; dir!=end;) {
+ try {
+- Glib::Dir::Dir directory(*dir++);
++ Glib::Dir directory(*dir++);
+ #endif /* GLIBMM_REGEX */
+ for ( Glib::DirIterator iter=directory.begin(); iter!=directory.end(); iter++ ) {
+ Gtk::TreeModel::Row rowCompletion = *(refCompletionModel->append());
+@@ -1259,7 +1259,7 @@
+
+ for ( std::vector<Glib::ustring>::iterator iterPath = preferences.getPathsIcons().begin(); iterPath!=preferences.getPathsIcons().end(); iterPath++ ) {
+ try {
+- Glib::Dir::Dir directory(*iterPath);
++ Glib::Dir directory(*iterPath);
+ for ( Glib::DirIterator iter=directory.begin(); iter!=directory.end(); iter++ ) {
+ Glib::ustring icon_name = *iter;
+ if ( icon_name.find(command_name)!=Glib::ustring::npos ) {
diff --git a/x11-misc/fme/fme-1.1.2.ebuild b/x11-misc/fme/fme-1.1.2.ebuild
index 38907d6a789e..8e4753d8c944 100644
--- a/x11-misc/fme/fme-1.1.2.ebuild
+++ b/x11-misc/fme/fme-1.1.2.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fme/fme-1.1.2.ebuild,v 1.1 2008/08/25 20:34:48 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fme/fme-1.1.2.ebuild,v 1.2 2010/05/06 11:18:59 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Graphical menu editor for Fluxbox menus"
HOMEPAGE="http://fme.rhymux.info/"
SRC_URI="http://fme.rhymux.info/stable/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -17,12 +19,15 @@ RDEPEND="sys-devel/bc
>=dev-cpp/gtkmm-2.4
>=dev-cpp/glibmm-2.14.0
>=dev-cpp/libglademm-2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-DEPEND="dev-util/pkgconfig
- ${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ emake DESTDIR="${D}" install || die
doicon glade/${PN}.png
make_desktop_entry ${PN} "Fluxbox Menu Editor" ${PN} "Settings;DesktopSettings"