summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-18 17:18:40 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-18 17:18:40 +0000
commit1120fab01dae1951a92b1adef7b2b766e618327f (patch)
tree1398da5581f247be480890f6c65dc267942aab22 /x11-misc/fluxter
parentStable on x86 wrt bug #199547 (diff)
downloadgentoo-2-1120fab01dae1951a92b1adef7b2b766e618327f.tar.gz
gentoo-2-1120fab01dae1951a92b1adef7b2b766e618327f.tar.bz2
gentoo-2-1120fab01dae1951a92b1adef7b2b766e618327f.zip
Fix building with --as-needed & amd64 stable.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-misc/fluxter')
-rw-r--r--x11-misc/fluxter/ChangeLog6
-rw-r--r--x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch45
-rw-r--r--x11-misc/fluxter/fluxter-0.1.0.ebuild28
3 files changed, 69 insertions, 10 deletions
diff --git a/x11-misc/fluxter/ChangeLog b/x11-misc/fluxter/ChangeLog
index f1159a3b7f78..99f8d1f68f35 100644
--- a/x11-misc/fluxter/ChangeLog
+++ b/x11-misc/fluxter/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fluxter
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxter/ChangeLog,v 1.13 2007/03/19 01:20:40 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxter/ChangeLog,v 1.14 2007/11/18 17:18:39 drac Exp $
+
+ 18 Nov 2007; Samuli Suominen <drac@gentoo.org>
+ +files/fluxter-0.1.0-asneeded.patch, fluxter-0.1.0.ebuild:
+ Fix building with --as-needed & amd64 stable.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch b/x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch
new file mode 100644
index 000000000000..3551ba307ac6
--- /dev/null
+++ b/x11-misc/fluxter/files/fluxter-0.1.0-asneeded.patch
@@ -0,0 +1,45 @@
+diff -ur fluxter-0.1.0.orig/Makefile.am fluxter-0.1.0/Makefile.am
+--- fluxter-0.1.0.orig/Makefile.am 2002-04-14 08:50:33.000000000 +0300
++++ fluxter-0.1.0/Makefile.am 2007-11-18 19:11:50.000000000 +0200
+@@ -17,4 +17,4 @@
+ NETInterface.cc NETInterface.hh \
+ blackboxstyle.hh
+ EXTRA_DIST = BUGS TODO
+-fluxter_LDADD = @X_LIBS@
++fluxter_LDADD = @LIBS@
+diff -ur fluxter-0.1.0.orig/configure.in fluxter-0.1.0/configure.in
+--- fluxter-0.1.0.orig/configure.in 2002-04-14 01:03:05.000000000 +0300
++++ fluxter-0.1.0/configure.in 2007-11-18 19:11:35.000000000 +0200
+@@ -18,14 +18,12 @@
+ [
+ test "$CFLAGS" = "" && CFLAGS="-g -Wall -DDEBUG"
+ test "$CXXFLAGS" = "" && CXXFLAGS="-g -Wall -DDEBUG"
+- test "$LDFLAGS" = "" && LDFLAGS=""
+ ])
+
+ AC_DEFUN(AC_SET_NODEBUG,
+ [
+- test "$CFLAGS" = "" && CFLAGS="-O2 -Wall"
+- test "$CXXFLAGS" = "" && CXXFLAGS="-O2 -Wall"
+- test "$LDFLAGS" = "" && LDFLAGS="-s"
++ test "$CFLAGS" = "" && CFLAGS="-Wall"
++ test "$CXXFLAGS" = "" && CXXFLAGS="-Wall"
+ ])
+
+
+@@ -71,12 +69,12 @@
+
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
++LIBS="$LIBS $X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
++AC_CHECK_LIB(X11, XOpenDisplay, LIBS="$LIBS -lX11",
+ AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++LIBS="$LIBS $X_EXTRA_LIBS"
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/x11-misc/fluxter/fluxter-0.1.0.ebuild b/x11-misc/fluxter/fluxter-0.1.0.ebuild
index ab06769994cf..4152e6d018ac 100644
--- a/x11-misc/fluxter/fluxter-0.1.0.ebuild
+++ b/x11-misc/fluxter/fluxter-0.1.0.ebuild
@@ -1,23 +1,33 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxter/fluxter-0.1.0.ebuild,v 1.13 2006/12/07 02:19:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fluxter/fluxter-0.1.0.ebuild,v 1.14 2007/11/18 17:18:39 drac Exp $
+
+inherit autotools eutils
DESCRIPTION="workspace pager dockapp, particularly useful with the Fluxbox window manager"
-HOMEPAGE="http://www.isomedia.com/homes/stevencooper/"
+HOMEPAGE="http://www.isomedia.com/homes/stevencooper"
SRC_URI="http://www.isomedia.com/homes/stevencooper/files/${P}.tar.gz"
-IUSE=""
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 hppa ppc x86 ~x86-fbsd"
+KEYWORDS="amd64 hppa ppc x86 ~x86-fbsd"
+IUSE=""
DEPEND="virtual/blackbox"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_compile() {
- econf --datadir=/usr/share/commonbox || die
- emake || die
+ econf --datadir=/usr/share/commonbox
+ emake || die "emake failed."
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc README COPYING AUTHORS ChangeLog NEWS README TODO
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc README AUTHORS ChangeLog NEWS README TODO
}