summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-02-16 16:39:33 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-02-16 16:39:33 +0000
commitf64519ad505a853c88c61af1e06aed40e18e5e26 (patch)
tree28faa7d11c7b3d59009dfd9f0ccc405cc9b0c53e /x11-misc/evolvotron
parentVersion bump from upstream, which fixes bug #113741, by Frederik Tolf (diff)
downloadgentoo-2-f64519ad505a853c88c61af1e06aed40e18e5e26.tar.gz
gentoo-2-f64519ad505a853c88c61af1e06aed40e18e5e26.tar.bz2
gentoo-2-f64519ad505a853c88c61af1e06aed40e18e5e26.zip
Fix compilation with Qt4 installed, see bug #123048.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'x11-misc/evolvotron')
-rw-r--r--x11-misc/evolvotron/ChangeLog8
-rw-r--r--x11-misc/evolvotron/Manifest12
-rw-r--r--x11-misc/evolvotron/evolvotron-0.3.1.ebuild9
-rw-r--r--x11-misc/evolvotron/files/digest-evolvotron-0.3.12
4 files changed, 24 insertions, 7 deletions
diff --git a/x11-misc/evolvotron/ChangeLog b/x11-misc/evolvotron/ChangeLog
index 1d6878c8f402..b4159468424e 100644
--- a/x11-misc/evolvotron/ChangeLog
+++ b/x11-misc/evolvotron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/evolvotron
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/ChangeLog,v 1.7 2005/07/07 05:18:26 caleb Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/ChangeLog,v 1.8 2006/02/16 16:39:32 nelchael Exp $
+
+ 16 Feb 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ evolvotron-0.3.1.ebuild:
+ Fix compilation with Qt4 installed, see bug #123048.
07 Jul 2005; Caleb Tennis <caleb@gentoo.org> evolvotron-0.3.1.ebuild:
Fix qt dep
diff --git a/x11-misc/evolvotron/Manifest b/x11-misc/evolvotron/Manifest
index 9baf4b594105..a130bbb79844 100644
--- a/x11-misc/evolvotron/Manifest
+++ b/x11-misc/evolvotron/Manifest
@@ -1,4 +1,12 @@
-MD5 bec5d6e7a59d64eb611fe5215b9977ff evolvotron-0.3.1.ebuild 938
MD5 732816489d699562aab4760dbe2cd009 ChangeLog 1018
+RMD160 32a67df99a8823da67d79bd1a8f25590a6db60eb ChangeLog 1018
+SHA256 cdb6bc73b3184a932c714c7a9881c46d94e144ecb5c29f39c871bbc60e75176c ChangeLog 1018
+MD5 c8aebbeeaa8bea0596673f10ce454ef2 evolvotron-0.3.1.ebuild 989
+RMD160 4931e0086c4702f527ed8915d054a79e9c84acde evolvotron-0.3.1.ebuild 989
+SHA256 a6533ee6f3e2cd9ee040f9d8a555c718504c3277120ef2bbd2b857d610a4ab5d evolvotron-0.3.1.ebuild 989
+MD5 7f43acb8b176f9ce25084e7bc7c582b8 files/digest-evolvotron-0.3.1 250
+RMD160 612ad046eaf2032f809cdceadd14150059e620c0 files/digest-evolvotron-0.3.1 250
+SHA256 d886dffd877ec762546e17289ec78a964553be4f21ef857a8947f922e730c0e5 files/digest-evolvotron-0.3.1 250
MD5 8dad4c602e8fc48cf21cf32d762b9af0 metadata.xml 231
-MD5 03a2ea7677c6b7bd6dd2a5fad7519e5f files/digest-evolvotron-0.3.1 68
+RMD160 edee523a81eb20b171a5dd298e8507ecd49230f6 metadata.xml 231
+SHA256 f9af69429b315694d8f6094781bf242d6235450fc58aba6e9e35e28099cc334a metadata.xml 231
diff --git a/x11-misc/evolvotron/evolvotron-0.3.1.ebuild b/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
index 2d788058fb61..2ac2b65639af 100644
--- a/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
+++ b/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/evolvotron-0.3.1.ebuild,v 1.4 2005/07/07 05:18:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/evolvotron-0.3.1.ebuild,v 1.5 2006/02/16 16:39:32 nelchael Exp $
+
+inherit qt3
DESCRIPTION="An interactive generative art application"
HOMEPAGE="http://www.bottlenose.demon.co.uk/share/evolvotron/index.htm"
@@ -11,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 ~amd64 ~ppc"
IUSE=""
-DEPEND="=x11-libs/qt-3*"
+DEPEND="$(qt_min_version 3)"
S="${WORKDIR}/${PN}"
@@ -25,6 +27,7 @@ src_unpack() {
}
src_compile() {
+ export PATH=${QTDIR}/bin:${PATH}
econf fs || die
emake -j1 || die "emake failed"
}
diff --git a/x11-misc/evolvotron/files/digest-evolvotron-0.3.1 b/x11-misc/evolvotron/files/digest-evolvotron-0.3.1
index 956f00b410e3..30fef73f8ebd 100644
--- a/x11-misc/evolvotron/files/digest-evolvotron-0.3.1
+++ b/x11-misc/evolvotron/files/digest-evolvotron-0.3.1
@@ -1 +1,3 @@
MD5 e6c8404d7c454283fb5d8f00ec0c2761 evolvotron-0.3.1.tar.gz 129201
+RMD160 e855ff686347d70c6d0251332f4ce6ff3768bea9 evolvotron-0.3.1.tar.gz 129201
+SHA256 2cd56c25335d2875a52cb638294e1597cabfcf955f6828fbd0b67199556cf636 evolvotron-0.3.1.tar.gz 129201