summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-20 05:23:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-20 05:23:12 +0000
commit0d6ecc77b510d26d0bd711c9b709c6329d523a6e (patch)
tree487d93b22b6a9a1f7667b930b5e4db8a8e0edf0a /x11-misc/entrance
parentupdate snapshot (diff)
downloadgentoo-2-0d6ecc77b510d26d0bd711c9b709c6329d523a6e.tar.gz
gentoo-2-0d6ecc77b510d26d0bd711c9b709c6329d523a6e.tar.bz2
gentoo-2-0d6ecc77b510d26d0bd711c9b709c6329d523a6e.zip
update snapshot
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-misc/entrance')
-rw-r--r--x11-misc/entrance/entrance-0.9.0.004.ebuild71
-rw-r--r--x11-misc/entrance/files/digest-entrance-0.9.0.0042
2 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/entrance/entrance-0.9.0.004.ebuild b/x11-misc/entrance/entrance-0.9.0.004.ebuild
new file mode 100644
index 000000000000..b9befc696863
--- /dev/null
+++ b/x11-misc/entrance/entrance-0.9.0.004.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.004.ebuild,v 1.1 2005/08/20 05:20:37 vapier Exp $
+
+inherit enlightenment eutils
+
+DESCRIPTION="next generation of Elogin, a login/display manager for X"
+HOMEPAGE="http://xcomputerman.com/pages/entrance.html"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/extraicons-1.tar.bz2
+ http://wh0rd.de/gentoo/distfiles/extraicons-1.tar.bz2"
+
+IUSE="pam"
+
+DEPEND="virtual/x11
+ pam? ( sys-libs/pam )
+ >=dev-db/edb-1.0.5
+ >=x11-libs/evas-0.9.9
+ >=x11-libs/ecore-0.9.9
+ >=media-libs/edje-0.5.0
+ >=x11-libs/esmart-0.9.0"
+
+src_unpack() {
+ enlightenment_src_unpack
+ cd "${S}"
+ epatch ${FILESDIR}/no-listen-tcp.patch
+}
+
+src_compile() {
+ if use pam ; then
+ export MY_ECONF="--with-auth-mode=pam"
+ else
+ export MY_ECONF="--with-auth-mode=shadow"
+ fi
+ enlightenment_src_compile
+}
+
+src_install() {
+ enlightenment_src_install
+ rm -rf ${D}/etc/init.d
+ insinto /usr/share/entrance/images/sessions
+ doins ${WORKDIR}/extraicons/*
+ exeinto /usr/share/entrance
+ doexe data/config/build_config.sh
+
+ cd /etc/X11/Sessions
+ local edb="${D}/etc/entrance_config.db"
+ local count="`edb_ed ${edb} get /entrance/session/count int`"
+ local datadir="${D}/usr/share/entrance/images/sessions"
+ local icon=""
+ while [ ${count} -ge 0 ] ; do
+ edb_ed ${edb} del /entrance/session/${count}/icon
+ edb_ed ${edb} del /entrance/session/${count}/session
+ edb_ed ${edb} del /entrance/session/${count}/title
+ count=$((${count} - 1))
+ done
+ count=0
+ for s in default * failsafe ; do
+ [ "${s}" == "Xsession" ] && continue
+ icon="`find ${datadir} -iname ${s}.png -printf %f`"
+ if [ -z "${icon}" ] ; then
+ edb_ed ${edb} add /entrance/session/${count}/icon str default.png
+ else
+ edb_ed ${edb} add /entrance/session/${count}/icon str ${icon}
+ fi
+ edb_ed ${edb} add /entrance/session/${count}/session str ${s}
+ edb_ed ${edb} add /entrance/session/${count}/title str ${s}
+ count=$((${count} + 1))
+ done
+ edb_ed ${edb} add /entrance/session/count int ${count}
+}
diff --git a/x11-misc/entrance/files/digest-entrance-0.9.0.004 b/x11-misc/entrance/files/digest-entrance-0.9.0.004
new file mode 100644
index 000000000000..6d1943e6ae9b
--- /dev/null
+++ b/x11-misc/entrance/files/digest-entrance-0.9.0.004
@@ -0,0 +1,2 @@
+MD5 48d8999a5be31e4b089e0faf40bf9fd9 entrance-0.9.0.004.tar.gz 16901820
+MD5 b1d2a452028c3a09443d84968e24144c extraicons-1.tar.bz2 16770