summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-15 12:16:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-15 12:16:01 +0000
commit0084c2f0c2bdcb498a55b492b6e719d08279c205 (patch)
tree2599de1688cd7c59cd914fae4d35caccd879cbf0 /x11-misc/electricsheep
parentStable for AMD64, wrt bug #393825 (diff)
downloadgentoo-2-0084c2f0c2bdcb498a55b492b6e719d08279c205.tar.gz
gentoo-2-0084c2f0c2bdcb498a55b492b6e719d08279c205.tar.bz2
gentoo-2-0084c2f0c2bdcb498a55b492b6e719d08279c205.zip
fix build with latest ffmpeg, bug #394213
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/electricsheep')
-rw-r--r--x11-misc/electricsheep/ChangeLog6
-rw-r--r--x11-misc/electricsheep/electricsheep-2.7_beta11.ebuild5
-rw-r--r--x11-misc/electricsheep/files/electricsheep-ffmpeg.patch41
3 files changed, 49 insertions, 3 deletions
diff --git a/x11-misc/electricsheep/ChangeLog b/x11-misc/electricsheep/ChangeLog
index 1831f8efcde2..c8d61e06533f 100644
--- a/x11-misc/electricsheep/ChangeLog
+++ b/x11-misc/electricsheep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/electricsheep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/ChangeLog,v 1.50 2011/07/20 15:07:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/ChangeLog,v 1.51 2011/12/15 12:16:01 aballier Exp $
+
+ 15 Dec 2011; Alexis Ballier <aballier@gentoo.org>
+ electricsheep-2.7_beta11.ebuild, +files/electricsheep-ffmpeg.patch:
+ fix build with latest ffmpeg, bug #394213
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #34534
diff --git a/x11-misc/electricsheep/electricsheep-2.7_beta11.ebuild b/x11-misc/electricsheep/electricsheep-2.7_beta11.ebuild
index 0df859f70fd4..a5d646402c0e 100644
--- a/x11-misc/electricsheep/electricsheep-2.7_beta11.ebuild
+++ b/x11-misc/electricsheep/electricsheep-2.7_beta11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/electricsheep-2.7_beta11.ebuild,v 1.6 2011/04/03 18:55:22 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/electricsheep/electricsheep-2.7_beta11.ebuild,v 1.7 2011/12/15 12:16:01 aballier Exp $
EAPI=2
inherit eutils flag-o-matic autotools
@@ -35,7 +35,8 @@ DEPEND="${DEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-xdg-utils.patch \
"${FILESDIR}"/${PN}-gnome.patch \
- "${FILESDIR}"/${P}-asneeded.patch
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${PN}-ffmpeg.patch
eautoreconf
}
diff --git a/x11-misc/electricsheep/files/electricsheep-ffmpeg.patch b/x11-misc/electricsheep/files/electricsheep-ffmpeg.patch
new file mode 100644
index 000000000000..d40c171cb221
--- /dev/null
+++ b/x11-misc/electricsheep/files/electricsheep-ffmpeg.patch
@@ -0,0 +1,41 @@
+Index: electricsheep-2.7_beta11/electricsheep.c
+===================================================================
+--- electricsheep-2.7_beta11.orig/electricsheep.c
++++ electricsheep-2.7_beta11/electricsheep.c
+@@ -61,6 +61,9 @@
+ #define STATFS statfs
+ #endif
+
++#ifndef guess_format
++#define guess_format av_guess_format
++#endif
+
+ prefs_t prefs;
+
+@@ -662,7 +665,7 @@ void copy_out_file(char *fname) {
+ input_stream_index = -1;
+ for (j = 0; j < ictx->nb_streams; j++) {
+ AVCodecContext *enc = ictx->streams[j]->codec;
+- if (CODEC_TYPE_VIDEO == enc->codec_type) {
++ if (AVMEDIA_TYPE_VIDEO == enc->codec_type) {
+ input_stream_index = j;
+ break;
+ }
+@@ -686,7 +689,7 @@ void copy_out_file(char *fname) {
+ }
+ }
+
+- output_ctx = av_alloc_format_context();
++ output_ctx = avformat_alloc_context();
+
+ ofmt = guess_format(NULL, fname, NULL);
+ if (!ofmt) {
+@@ -730,7 +733,7 @@ void copy_out_file(char *fname) {
+ av_init_packet(&opkt);
+ if (av_parser_change(ictx->streams[input_stream_index]->parser, output_ctx->streams[0]->codec,
+ &opkt.data, &opkt.size, ipkt.data, ipkt.size,
+- ipkt.flags & PKT_FLAG_KEY))
++ ipkt.flags & AV_PKT_FLAG_KEY))
+ opkt.destruct= av_destruct_packet;
+
+ if (-1 == av_interleaved_write_frame(output_ctx, &opkt)) {