summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-10-06 20:31:28 +0000
committerJeroen Roovers <jer@gentoo.org>2011-10-06 20:31:28 +0000
commit894c4bff1f0cd2810a8823def3a802f67220e8b7 (patch)
tree4a08ee7e2c00330a3ea0d2d4317a70e73780718f /x11-misc/dmenu
parentLastrite londonlaw and xpilot-ng. (diff)
downloadgentoo-2-894c4bff1f0cd2810a8823def3a802f67220e8b7.tar.gz
gentoo-2-894c4bff1f0cd2810a8823def3a802f67220e8b7.tar.bz2
gentoo-2-894c4bff1f0cd2810a8823def3a802f67220e8b7.zip
Version bump, block app-misc/lsx and net-dialup/lrzsz (bug #376675). Do not install README (bug #369541). Drop -g from CFLAGS (bug #378651).
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/dmenu')
-rw-r--r--x11-misc/dmenu/ChangeLog8
-rw-r--r--x11-misc/dmenu/dmenu-4.4.1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index 0b72938e47a2..baa4fdfb2bb1 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.68 2011/05/31 08:15:38 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.69 2011/10/06 20:31:28 jer Exp $
+
+*dmenu-4.4.1 (06 Oct 2011)
+
+ 06 Oct 2011; Jeroen Roovers <jer@gentoo.org> +dmenu-4.4.1.ebuild:
+ Version bump, block app-misc/lsx and net-dialup/lrzsz (bug #376675). Do not
+ install README (bug #369541). Drop -g from CFLAGS (bug #378651).
*dmenu-4.3.1 (31 May 2011)
diff --git a/x11-misc/dmenu/dmenu-4.4.1.ebuild b/x11-misc/dmenu/dmenu-4.4.1.ebuild
new file mode 100644
index 000000000000..ac095e2b651c
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-4.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-4.4.1.ebuild,v 1.1 2011/10/06 20:31:28 jer Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.suckless.org/programs/dmenu.html"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ !app-misc/lsx
+ !net-dialup/lrzsz"
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -ansi -pedantic -Wall -Os/CFLAGS += -ansi -pedantic -Wall/" \
+ -e "s/LDFLAGS = -s/LDFLAGS +=/" \
+ -e "s/XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ if use xinerama; then
+ emake CC=$(tc-getCC)
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS=""
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}