summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-12 20:47:00 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-12 20:47:00 +0000
commitae923ec86cd891dfae7a243a34c27e6d4c518413 (patch)
treeddc3241c5df4fe63fb167dd7e52b428177661b5e /x11-misc/compton
parentVersion bump (diff)
downloadgentoo-2-ae923ec86cd891dfae7a243a34c27e6d4c518413.tar.gz
gentoo-2-ae923ec86cd891dfae7a243a34c27e6d4c518413.tar.bz2
gentoo-2-ae923ec86cd891dfae7a243a34c27e6d4c518413.zip
version bump, remove old, update live ebuild
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc/compton')
-rw-r--r--x11-misc/compton/ChangeLog10
-rw-r--r--x11-misc/compton/compton-0.1_beta1.ebuild68
-rw-r--r--x11-misc/compton/compton-0_pre20120330.ebuild33
-rw-r--r--x11-misc/compton/compton-0_pre20120913.ebuild33
-rw-r--r--x11-misc/compton/compton-0_pre20121114.ebuild44
-rw-r--r--x11-misc/compton/compton-9999.ebuild17
6 files changed, 89 insertions, 116 deletions
diff --git a/x11-misc/compton/ChangeLog b/x11-misc/compton/ChangeLog
index c11e36759bf5..1168c6b28d5d 100644
--- a/x11-misc/compton/ChangeLog
+++ b/x11-misc/compton/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/compton
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/ChangeLog,v 1.12 2013/01/29 11:19:36 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/ChangeLog,v 1.13 2013/08/12 20:47:00 hasufell Exp $
+
+*compton-0.1_beta1 (12 Aug 2013)
+
+ 12 Aug 2013; Julian Ospald <hasufell@gentoo.org>
+ -compton-0_pre20120330.ebuild, -compton-0_pre20120913.ebuild,
+ -compton-0_pre20121114.ebuild, +compton-0.1_beta1.ebuild,
+ compton-9999.ebuild:
+ version bump, remove old, update live ebuild
29 Jan 2013; Julian Ospald <hasufell@gentoo.org> compton-9999.ebuild:
update live ebuild: install additional examples
diff --git a/x11-misc/compton/compton-0.1_beta1.ebuild b/x11-misc/compton/compton-0.1_beta1.ebuild
new file mode 100644
index 000000000000..1ccf5f53fbeb
--- /dev/null
+++ b/x11-misc/compton/compton-0.1_beta1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0.1_beta1.ebuild,v 1.1 2013/08/12 20:47:00 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_2 python3_3 )
+inherit toolchain-funcs python-r1
+
+DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
+HOMEPAGE="http://github.com/chjj/compton"
+SRC_URI="https://github.com/chjj/compton/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +drm opengl +pcre"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/libconfig
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ dbus? ( sys-apps/dbus )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre:3 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-apps/xwininfo
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+ x11-proto/xproto
+ drm? ( x11-libs/libdrm )"
+
+nobuildit() { use $1 || echo yes ; }
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ emake docs
+ NO_DBUS=$(nobuildit dbus) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ emake compton
+}
+
+src_install() {
+ NO_DBUS=$(nobuildit dbus) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ default
+ docinto examples
+ dodoc compton.sample.conf dbus-examples/*
+ python_foreach_impl python_newscript bin/compton-convgen.py compton-convgen
+}
diff --git a/x11-misc/compton/compton-0_pre20120330.ebuild b/x11-misc/compton/compton-0_pre20120330.ebuild
deleted file mode 100644
index 36ffe82f447e..000000000000
--- a/x11-misc/compton/compton-0_pre20120330.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20120330.ebuild,v 1.4 2012/05/06 00:14:51 hasufell Exp $
-
-EAPI=4
-
-inherit toolchain-funcs
-
-DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
-HOMEPAGE="http://github.com/chjj/compton"
-SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrender"
-RDEPEND="${COMMON_DEPEND}
- app-shells/bash
- x11-apps/xprop
- x11-apps/xwininfo"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- x11-proto/xproto"
-
-pkg_setup() {
- tc-export CC
-}
diff --git a/x11-misc/compton/compton-0_pre20120913.ebuild b/x11-misc/compton/compton-0_pre20120913.ebuild
deleted file mode 100644
index 62c819fbac70..000000000000
--- a/x11-misc/compton/compton-0_pre20120913.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20120913.ebuild,v 1.1 2012/09/24 11:20:28 hasufell Exp $
-
-EAPI=4
-
-inherit toolchain-funcs
-
-DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
-HOMEPAGE="http://github.com/chjj/compton"
-SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrender"
-RDEPEND="${COMMON_DEPEND}
- app-shells/bash
- x11-apps/xprop
- x11-apps/xwininfo"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- x11-proto/xproto"
-
-pkg_setup() {
- tc-export CC
-}
diff --git a/x11-misc/compton/compton-0_pre20121114.ebuild b/x11-misc/compton/compton-0_pre20121114.ebuild
deleted file mode 100644
index 7b37435f3770..000000000000
--- a/x11-misc/compton/compton-0_pre20121114.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20121114.ebuild,v 1.1 2012/11/17 23:24:46 hasufell Exp $
-
-EAPI=5
-
-inherit toolchain-funcs
-
-DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
-HOMEPAGE="http://github.com/chjj/compton"
-SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="dev-libs/libconfig
- virtual/opengl
- dev-libs/libpcre:3
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXrender"
-RDEPEND="${COMMON_DEPEND}
- app-shells/bash
- x11-apps/xprop
- x11-apps/xwininfo"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- x11-libs/libdrm
- x11-proto/xproto"
-
-pkg_setup() {
- tc-export CC
-}
-
-src_install() {
- default
- dodoc compton.sample.conf
-}
diff --git a/x11-misc/compton/compton-9999.ebuild b/x11-misc/compton/compton-9999.ebuild
index 3a2ce3c8bb1e..792f1d36f91e 100644
--- a/x11-misc/compton/compton-9999.ebuild
+++ b/x11-misc/compton/compton-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-9999.ebuild,v 1.6 2013/01/29 11:19:36 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-9999.ebuild,v 1.7 2013/08/12 20:47:00 hasufell Exp $
EAPI=5
-inherit toolchain-funcs git-2
+PYTHON_COMPAT=( python3_2 python3_3 )
+inherit toolchain-funcs python-r1 git-2
DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
HOMEPAGE="http://github.com/chjj/compton"
@@ -16,8 +17,10 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS=""
IUSE="dbus +drm opengl +pcre"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-COMMON_DEPEND="dev-libs/libconfig
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/libconfig
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXdamage
@@ -30,7 +33,8 @@ COMMON_DEPEND="dev-libs/libconfig
pcre? ( dev-libs/libpcre:3 )"
RDEPEND="${COMMON_DEPEND}
x11-apps/xprop
- x11-apps/xwininfo"
+ x11-apps/xwininfo
+ virtual/python-argparse[${PYTHON_USEDEP}]"
DEPEND="${COMMON_DEPEND}
app-text/asciidoc
virtual/pkgconfig
@@ -40,7 +44,9 @@ DEPEND="${COMMON_DEPEND}
nobuildit() { use $1 || echo yes ; }
pkg_setup() {
- tc-export CC
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CC
+ fi
}
src_compile() {
@@ -60,4 +66,5 @@ src_install() {
default
docinto examples
nonfatal dodoc compton.sample.conf dbus-examples/*
+ python_foreach_impl python_newscript bin/compton-convgen.py compton-convgen
}