summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-25 23:21:35 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-25 23:21:35 +0000
commitfc2e8ca4cd62567db24a01395a9c7a810ae6cc2a (patch)
treed8a96e77b004d444cae5462e4cdcccf053712991 /x11-misc/colord
parentVersion bump. (diff)
downloadgentoo-2-fc2e8ca4cd62567db24a01395a9c7a810ae6cc2a.tar.gz
gentoo-2-fc2e8ca4cd62567db24a01395a9c7a810ae6cc2a.tar.bz2
gentoo-2-fc2e8ca4cd62567db24a01395a9c7a810ae6cc2a.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-misc/colord')
-rw-r--r--x11-misc/colord/ChangeLog7
-rw-r--r--x11-misc/colord/colord-1.2.0.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/x11-misc/colord/ChangeLog b/x11-misc/colord/ChangeLog
index 50ea02cf42c0..8480b8edb50a 100644
--- a/x11-misc/colord/ChangeLog
+++ b/x11-misc/colord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/colord
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/ChangeLog,v 1.72 2014/03/29 22:04:07 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/ChangeLog,v 1.73 2014/04/25 23:21:35 eva Exp $
+
+*colord-1.2.0 (25 Apr 2014)
+
+ 25 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +colord-1.2.0.ebuild:
+ Version bump.
29 Mar 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
colord-0.1.28.ebuild, colord-1.0.3.ebuild:
diff --git a/x11-misc/colord/colord-1.2.0.ebuild b/x11-misc/colord/colord-1.2.0.ebuild
new file mode 100644
index 000000000000..d136fc59ab4a
--- /dev/null
+++ b/x11-misc/colord/colord-1.2.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/colord-1.2.0.ebuild,v 1.1 2014/04/25 23:21:35 eva Exp $
+
+EAPI="5"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.18"
+
+inherit bash-completion-r1 check-reqs eutils user systemd base udev vala
+
+DESCRIPTION="System service to accurately color manage input and output devices"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/2" # subslot = libcolord soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples extra-print-profiles +gusb +introspection scanner systemd +udev vala"
+REQUIRED_USE="
+ gusb? ( udev )
+ scanner? ( udev )
+ vala? ( introspection )"
+
+COMMON_DEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.36:2
+ >=media-libs/lcms-2.5:2=
+ >=sys-auth/polkit-0.103
+ gusb? ( >=dev-libs/libgusb-0.1.1[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
+ scanner? ( media-gfx/sane-backends )
+ systemd? ( >=sys-apps/systemd-44:0= )
+ udev? ( virtual/udev:=[gudev] )"
+RDEPEND="${COMMON_DEPEND}
+ !media-gfx/shared-color-profiles"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ extra-print-profiles? ( media-gfx/argyllcms )
+ vala? ( $(vala_depend) )"
+
+# FIXME: needs pre-installed dbus service files
+RESTRICT="test"
+
+# According to upstream comment in colord.spec.in, building the extra print
+# profiles requires >=4G of memory
+CHECKREQS_MEMORY="4G"
+
+pkg_pretend() {
+ use extra-print-profiles && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use extra-print-profiles && check-reqs_pkg_setup
+ enewgroup colord
+ enewuser colord -1 -1 /var/lib/colord colord
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ # Reverse tools require gusb
+ # bash-completion test does not work on gentoo
+ econf \
+ --disable-bash-completion \
+ --disable-examples \
+ --disable-gtk-doc \
+ --disable-static \
+ --enable-polkit \
+ --enable-libcolordcompat \
+ --with-daemon-user=colord \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable extra-print-profiles print-profiles) \
+ $(usex extra-print-profiles COLPROF="$(type -P argyll-colprof)" "") \
+ $(use_enable gusb) \
+ $(use_enable gusb reverse) \
+ $(use_enable introspection) \
+ $(use_enable scanner sane) \
+ $(use_enable systemd systemd-login) \
+ $(use_enable udev) \
+ --with-udevrulesdir="$(udev_get_udevdir)"/rules.d \
+ $(use_enable vala) \
+ "$(systemd_with_unitdir)"
+}
+
+src_install() {
+ DOCS=(AUTHORS ChangeLog MAINTAINERS NEWS README.md TODO)
+ default
+
+ newbashcomp data/colormgr colormgr
+ rm -vr "${ED}etc/bash_completion.d"
+
+ # Ensure config and profile directories exist and /var/lib/colord/*
+ # is writable by colord user
+ keepdir /var/lib/color{,d}/icc
+ fowners colord:colord /var/lib/colord{,/icc}
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+
+ prune_libtool_files --modules
+}