summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-28 17:28:42 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-28 17:28:42 +0000
commitf6ba621325d2757f1d6e26436ccbc0509aabf9a3 (patch)
tree4f33e9be47707d77e052a0222a28549a1148d026 /x11-misc/bbrun/files
parentFix configuration (bug #321783). (diff)
downloadgentoo-2-f6ba621325d2757f1d6e26436ccbc0509aabf9a3.tar.gz
gentoo-2-f6ba621325d2757f1d6e26436ccbc0509aabf9a3.tar.bz2
gentoo-2-f6ba621325d2757f1d6e26436ccbc0509aabf9a3.zip
Adding missing dependency and respect user flags. Thanks Patrick for the report and Andrew Brouwers for patch.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/bbrun/files')
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-respectflags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch b/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch
new file mode 100644
index 000000000000..d81824b0ed0f
--- /dev/null
+++ b/x11-misc/bbrun/files/bbrun-1.6-respectflags.patch
@@ -0,0 +1,26 @@
+Respect {C,LD}FLAGS
+
+--- bbrun/Makefile
++++ bbrun/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ LIBDIR = -L/usr/lib -L/usr/X11R6/lib
+ LIBS = -lXpm `pkg-config --libs gtk+-2.0`
+-CFLAGS = `pkg-config --cflags gtk+-2.0`
++GTK_CFLAGS = `pkg-config --cflags gtk+-2.0`
+
+ OBJS = bbrun.o \
+ ../wmgeneral/wmgeneral.o \
+@@ -11,10 +11,10 @@
+ all: bbrun
+
+ .c.o:
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) $(GTK_CFLAGS) -c -Wall $< -o $*.o
+
+ bbrun: $(OBJS)
+- $(CC) -Wall -g -o bbrun $^ $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -o bbrun $^ $(LIBDIR) $(LIBS)
+
+ install:
+ cp bbrun /usr/local/bin/