summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-07-03 13:51:05 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-07-03 13:51:05 +0000
commit0091f3db42b7890a8e0a61b996f4fdbaff17d230 (patch)
treec3618f6e1522f83d09ccf07313bcef50c6fb40d0 /x11-misc/bblaunch
parentWrong KEYWORDS. (Manifest recommit) (diff)
downloadgentoo-2-0091f3db42b7890a8e0a61b996f4fdbaff17d230.tar.gz
gentoo-2-0091f3db42b7890a8e0a61b996f4fdbaff17d230.tar.bz2
gentoo-2-0091f3db42b7890a8e0a61b996f4fdbaff17d230.zip
Patch to fix segmentation fault problem. Closing bug #53998.
Diffstat (limited to 'x11-misc/bblaunch')
-rw-r--r--x11-misc/bblaunch/ChangeLog4
-rw-r--r--x11-misc/bblaunch/bblaunch-0.0.3.ebuild3
-rw-r--r--x11-misc/bblaunch/files/bblaunch-0.0.3.patch11
3 files changed, 17 insertions, 1 deletions
diff --git a/x11-misc/bblaunch/ChangeLog b/x11-misc/bblaunch/ChangeLog
index fc01f6bf3994..eb1f6f047760 100644
--- a/x11-misc/bblaunch/ChangeLog
+++ b/x11-misc/bblaunch/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
# $Header
+ 03 Jul 2004; <pyrania@gentoo.org> +files/bblaunch-0.0.3.patch,
+ bblaunch-0.0.3.ebuild:
+ Patch to fix segmentation fault problem. Closing bug #53998.
+
14 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> bblaunch-0.0.3.ebuild:
Removed S=, added IUSE=
diff --git a/x11-misc/bblaunch/bblaunch-0.0.3.ebuild b/x11-misc/bblaunch/bblaunch-0.0.3.ebuild
index 0c874472bc6f..6371a94a0078 100644
--- a/x11-misc/bblaunch/bblaunch-0.0.3.ebuild
+++ b/x11-misc/bblaunch/bblaunch-0.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bblaunch/bblaunch-0.0.3.ebuild,v 1.8 2004/06/24 22:12:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bblaunch/bblaunch-0.0.3.ebuild,v 1.9 2004/07/03 13:51:05 pyrania Exp $
IUSE=""
DESCRIPTION="An application launcher for Blackbox type window managers"
@@ -13,6 +13,7 @@ KEYWORDS="x86 ppc"
DEPEND="virtual/blackbox"
src_compile () {
+ epatch ${FILESDIR}/${P}.patch
econf || die
emake || die
}
diff --git a/x11-misc/bblaunch/files/bblaunch-0.0.3.patch b/x11-misc/bblaunch/files/bblaunch-0.0.3.patch
new file mode 100644
index 000000000000..3c78fab2ec77
--- /dev/null
+++ b/x11-misc/bblaunch/files/bblaunch-0.0.3.patch
@@ -0,0 +1,11 @@
+--- bblaunch.c.orig 2002-05-06 23:35:57.000000000 -0500
++++ bblaunch.c 2004-06-15 07:21:11.080972712 -0500
+@@ -170,7 +170,7 @@
+ launchargs.iconic = False;
+ launchargs.pause = 1000;
+
+- sprintf(launchargs.call, "%s", (char *)atoi(argv[0]));
++ sprintf(launchargs.call, "%s", argv[0]);
+
+ i = 1;
+ valargs = 1;