summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-05-17 18:26:24 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-05-17 18:26:24 +0000
commit1447cdbaa16850e000d5453a033b33f2564958e9 (patch)
treeb8357d1596c81017232bf5f5b73be045f674a029 /x11-misc/basket
parentFixed clvmd start order. Thanks to Frank Schliefer <f_schliefer@vcc.de>. (diff)
downloadgentoo-2-1447cdbaa16850e000d5453a033b33f2564958e9.tar.gz
gentoo-2-1447cdbaa16850e000d5453a033b33f2564958e9.tar.bz2
gentoo-2-1447cdbaa16850e000d5453a033b33f2564958e9.zip
Add patch by Panard <panard@inzenet.org> for compilation on amd64 (bug #133100), remove old version.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'x11-misc/basket')
-rw-r--r--x11-misc/basket/ChangeLog8
-rw-r--r--x11-misc/basket/basket-0.5.0.ebuild4
-rw-r--r--x11-misc/basket/files/basket-0.5.0-amd64-gcc4.1.patch14
3 files changed, 23 insertions, 3 deletions
diff --git a/x11-misc/basket/ChangeLog b/x11-misc/basket/ChangeLog
index 0125dc70b166..adb9c769cee4 100644
--- a/x11-misc/basket/ChangeLog
+++ b/x11-misc/basket/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/basket
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/basket/ChangeLog,v 1.12 2006/04/28 00:16:06 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/basket/ChangeLog,v 1.13 2006/05/17 18:26:24 nelchael Exp $
+
+ 17 May 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/basket-0.5.0-amd64-gcc4.1.patch, -basket-0.4.0d.ebuild,
+ basket-0.5.0.ebuild:
+ Add patch by Panard <panard@inzenet.org> for compilation on amd64 (bug
+ #133100), remove old version.
28 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-basket-0.4.0d,
files/digest-basket-0.5.0, Manifest:
diff --git a/x11-misc/basket/basket-0.5.0.ebuild b/x11-misc/basket/basket-0.5.0.ebuild
index 03cf7f8ae6b5..2064d38b749f 100644
--- a/x11-misc/basket/basket-0.5.0.ebuild
+++ b/x11-misc/basket/basket-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/basket/basket-0.5.0.ebuild,v 1.5 2006/03/22 22:17:04 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/basket/basket-0.5.0.ebuild,v 1.6 2006/05/17 18:26:24 nelchael Exp $
inherit eutils kde
@@ -21,5 +21,5 @@ src_unpack() {
# patch from basket developer to solve compilation
# problemes on systems without arts
use arts || epatch ${FILESDIR}/${P}-noarts.patch
+ use amd64 && epatch ${FILESDIR}/${P}-amd64-gcc4.1.patch
}
-
diff --git a/x11-misc/basket/files/basket-0.5.0-amd64-gcc4.1.patch b/x11-misc/basket/files/basket-0.5.0-amd64-gcc4.1.patch
new file mode 100644
index 000000000000..8ae8f6ae78e2
--- /dev/null
+++ b/x11-misc/basket/files/basket-0.5.0-amd64-gcc4.1.patch
@@ -0,0 +1,14 @@
+diff -ur basket-0.5.0.orig/src/item.cpp basket-0.5.0/src/item.cpp
+--- basket-0.5.0.orig/src/item.cpp 2006-05-12 12:05:34.000000000 +0200
++++ basket-0.5.0/src/item.cpp 2006-05-12 12:05:55.000000000 +0200
+@@ -422,8 +422,8 @@
+ if (selected == m_isSelected)
+ return;
+
+- DEBUG_WIN << QString(selected ? "Add" : "Remove") + " selected item " + QString::number((int)this) +
+- "; b.lastIn=" + QString::number((int)(parentBasket()->lastInsertedItem()));
++ DEBUG_WIN << QString(selected ? "Add" : "Remove") + " selected item " + QString::number((long int)this) +
++ "; b.lastIn=" + QString::number((long int)(parentBasket()->lastInsertedItem()));
+
+ m_isSelected = selected;
+ if (selected) {