summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-11-20 13:11:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-11-20 13:11:22 +0000
commit93569205ee70565c7f547fabcf397883eeecd5e7 (patch)
tree8cb3656da67bf4d849f4d7e31c7aae3e07124370 /x11-misc/alltray
parentVersion bump: google jingle support can be enable/disabled via USE flag, maki... (diff)
downloadgentoo-2-93569205ee70565c7f547fabcf397883eeecd5e7.tar.gz
gentoo-2-93569205ee70565c7f547fabcf397883eeecd5e7.tar.bz2
gentoo-2-93569205ee70565c7f547fabcf397883eeecd5e7.zip
Rename 0.74 as 0.7.4 to match upstream versioning scheme.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'x11-misc/alltray')
-rw-r--r--x11-misc/alltray/ChangeLog8
-rw-r--r--x11-misc/alltray/alltray-0.7.4.ebuild36
-rw-r--r--x11-misc/alltray/alltray-0.74.ebuild45
3 files changed, 43 insertions, 46 deletions
diff --git a/x11-misc/alltray/ChangeLog b/x11-misc/alltray/ChangeLog
index f8fa21bfc593..e0f60ba28370 100644
--- a/x11-misc/alltray/ChangeLog
+++ b/x11-misc/alltray/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/alltray
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/alltray/ChangeLog,v 1.40 2011/11/20 13:07:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alltray/ChangeLog,v 1.41 2011/11/20 13:11:22 ssuominen Exp $
+
+*alltray-0.7.4 (20 Nov 2011)
+
+ 20 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> +alltray-0.7.4.ebuild,
+ -alltray-0.74.ebuild:
+ Rename 0.74 as 0.7.4 to match upstream versioning scheme.
*alltray-0.7.5.1 (20 Nov 2011)
diff --git a/x11-misc/alltray/alltray-0.7.4.ebuild b/x11-misc/alltray/alltray-0.7.4.ebuild
new file mode 100644
index 000000000000..185c41bbf93c
--- /dev/null
+++ b/x11-misc/alltray/alltray-0.7.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alltray/alltray-0.7.4.ebuild,v 1.1 2011/11/20 13:11:22 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P=${P}dev
+
+DESCRIPTION="Dock any application into the system tray/notification area"
+HOMEPAGE="http://alltray.trausch.us/"
+SRC_URI="http://code.launchpad.net/${PN}/trunk/${PV}dev/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ gnome-base/libgtop:2
+ x11-libs/libwnck:1
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include-fixes.patch
+
+ # Drop DEPRECATED flags, bug #391101
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED::' src/Makefile.{am,in} || die
+}
diff --git a/x11-misc/alltray/alltray-0.74.ebuild b/x11-misc/alltray/alltray-0.74.ebuild
deleted file mode 100644
index a20bdfb8cba0..000000000000
--- a/x11-misc/alltray/alltray-0.74.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/alltray/alltray-0.74.ebuild,v 1.6 2011/11/20 12:30:26 pacho Exp $
-
-# remove this kludge once old releases have been removed from the tree
-MY_PV="${PV:0:1}.${PV:2:1}.${PV:3:1}"
-MY_PV_DEV="${MY_PV}dev"
-MY_P="${PN}-${MY_PV}"
-MY_P_DEV="${PN}-${MY_PV_DEV}"
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="Dock any application into the system tray/notification area"
-HOMEPAGE="http://alltray.trausch.us/"
-SRC_URI="http://code.launchpad.net/${PN}/trunk/${MY_PV_DEV}/+download/${MY_P_DEV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="x11-libs/gtk+:2
- dev-libs/glib:2
- gnome-base/libgtop:2
- x11-libs/libwnck:1
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9.0"
-
-S="${WORKDIR}/${MY_P_DEV}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${MY_P}-include-fixes.patch
-
- # Drop DEPRECATED flags, bug #391101
- sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED::' \
- src/Makefile.am src/Makefile.in || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README || die "dodoc failed"
-}