summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-21 22:31:23 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-21 22:31:23 +0000
commitbda0cadf80bb51712f1034c92d3234e8b920701e (patch)
tree777955ba5081eea5b0fad13d1805e5bae1380c51 /x11-misc/alacarte
parentremove old (diff)
downloadgentoo-2-bda0cadf80bb51712f1034c92d3234e8b920701e.tar.gz
gentoo-2-bda0cadf80bb51712f1034c92d3234e8b920701e.tar.bz2
gentoo-2-bda0cadf80bb51712f1034c92d3234e8b920701e.zip
Bump to 0.11.7. Port to GIO, updated translations.
(Portage version: 2.2_rc22/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'x11-misc/alacarte')
-rw-r--r--x11-misc/alacarte/ChangeLog8
-rw-r--r--x11-misc/alacarte/alacarte-0.11.7.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-misc/alacarte/ChangeLog b/x11-misc/alacarte/ChangeLog
index 36b4a2e97bb6..d8ebc36e98c8 100644
--- a/x11-misc/alacarte/ChangeLog
+++ b/x11-misc/alacarte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/alacarte
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.61 2009/01/03 15:21:40 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.62 2009/01/21 22:31:23 eva Exp $
+
+*alacarte-0.11.7 (21 Jan 2009)
+
+ 21 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +alacarte-0.11.7.ebuild:
+ Bump to 0.11.7. Port to GIO, updated translations.
03 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
-files/alacarte-0.11.3-python-2.5.patch, -alacarte-0.11.4.ebuild,
diff --git a/x11-misc/alacarte/alacarte-0.11.7.ebuild b/x11-misc/alacarte/alacarte-0.11.7.ebuild
new file mode 100644
index 000000000000..c5aec5f4cf9c
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-0.11.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/alacarte-0.11.7.ebuild,v 1.1 2009/01/21 22:31:23 eva Exp $
+
+inherit gnome2 python eutils
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="http://www.realistanew.com/projects/alacarte"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+SLOT=0
+
+common_depends=">=dev-lang/python-2.4
+ >=dev-python/pygobject-2.15.1
+ >=dev-python/pygtk-2.8
+ >=gnome-base/gnome-menus-2.18
+ >=dev-python/libgnome-python-2.18"
+
+RDEPEND="${common_depends}
+ >=gnome-base/gnome-panel-2.16"
+
+DEPEND="${common_depends}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ if ! built_with_use gnome-base/gnome-menus python ; then
+ eerror "You must emerge gnome-base/gnome-menus with the python USE flag"
+ die "alacarte needs python support in gnome-base/gnome-menus"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/Alacarte
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/Alacarte
+}