summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-19 09:58:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-19 09:58:29 +0000
commitcf087bcaa5cefad6388a556f89524b783f1a9ed3 (patch)
tree44b553bd045872d1001e803be6c20aebc437a67b /x11-misc/3ddesktop
parentVersion bump. Removed old (diff)
downloadgentoo-2-cf087bcaa5cefad6388a556f89524b783f1a9ed3.tar.gz
gentoo-2-cf087bcaa5cefad6388a556f89524b783f1a9ed3.tar.bz2
gentoo-2-cf087bcaa5cefad6388a556f89524b783f1a9ed3.zip
Missing USE dep for imlib2. Tidy patches and include direct links to bugzilla in headers.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/3ddesktop')
-rw-r--r--x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild54
-rw-r--r--x11-misc/3ddesktop/ChangeLog11
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch2
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch7
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch7
5 files changed, 42 insertions, 39 deletions
diff --git a/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild b/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild
index ed64e55c013c..7058f7bdad0f 100644
--- a/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild
+++ b/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild,v 1.5 2012/02/16 18:24:45 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/3ddesktop-0.2.9-r1.ebuild,v 1.6 2012/06/19 09:58:29 ssuominen Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils
DESCRIPTION="OpenGL virtual desktop switching"
@@ -14,44 +14,42 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND="x11-libs/libX11
- x11-libs/libXmu
- x11-libs/libXt
+RDEPEND="media-libs/freeglut
+ >=media-libs/freetype-2
+ media-libs/imlib2[X]
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
- x11-libs/libXxf86vm
- media-libs/imlib2
- media-libs/freeglut
- media-libs/freetype"
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
DEPEND="${RDEPEND}
x11-proto/xf86vidmodeproto
x11-proto/xproto"
+DOCS="AUTHORS TODO ChangeLog README README.windowmanagers"
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc4.patch \
+ epatch \
+ "${FILESDIR}"/${P}-gcc4.patch \
"${FILESDIR}"/${P}-asneeded.patch \
"${FILESDIR}"/${P}-missing-include.patch \
"${FILESDIR}"/${P}-gl_init.patch
- eautoreconf
-}
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS TODO ChangeLog README README.windowmanagers
+ eautoreconf
}
pkg_postinst() {
- einfo
- einfo "This ebuild installed a configuration file called /etc/3ddesktop.conf"
- einfo "The default configuration makes a screenshot of the virtual desktops"
- einfo "every X seconds. This is non-optimal behavior."
- einfo
- einfo "To enable a more intelligent way of updating the virtual desktops,"
- einfo "execute the following:"
- einfo
- einfo " echo \"AutoAcquire 0\" >> /etc/3ddesktop.conf"
- einfo
- einfo "This will cause 3ddesktop to update the virtual desktop snapshots"
- einfo "only when a 3d desktop switch is required."
- einfo
+ echo
+ elog "This ebuild installed a configuration file called /etc/3ddesktop.conf"
+ elog "The default configuration makes a screenshot of the virtual desktops"
+ elog "every X seconds. This is non-optimal behavior."
+ elog
+ elog "To enable a more intelligent way of updating the virtual desktops,"
+ elog "execute the following:"
+ elog
+ elog " echo \"AutoAcquire 0\" >> /etc/3ddesktop.conf"
+ elog
+ elog "This will cause 3ddesktop to update the virtual desktop snapshots"
+ elog "only when a 3d desktop switch is required."
}
diff --git a/x11-misc/3ddesktop/ChangeLog b/x11-misc/3ddesktop/ChangeLog
index 47600cf94fff..aa58ea808d47 100644
--- a/x11-misc/3ddesktop/ChangeLog
+++ b/x11-misc/3ddesktop/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for x11-misc/3ddesktop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/ChangeLog,v 1.45 2012/02/17 04:12:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/ChangeLog,v 1.46 2012/06/19 09:58:29 ssuominen Exp $
+
+ 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ 3ddesktop-0.2.9-r1.ebuild:
+ Missing USE dependency media-libs/imlib2[X] wrt #421927
17 Feb 2012; Jeroen Roovers <jer@gentoo.org> -3ddesktop-0.2.9.ebuild:
- Old.
+ old
16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
3ddesktop-0.2.9-r1.ebuild:
@@ -36,9 +40,6 @@
files/3ddesktop-0.2.9-gcc4.patch:
Fix patch with absolute paths.
- 21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
- Redigest for Manifest2
-
22 Oct 2006; David Shakaryan <omp@gentoo.org> 3ddesktop-0.2.9.ebuild:
Remove monolithic X from dependencies.
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch
index 6e1ca15fd363..135472a323b6 100644
--- a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-asneeded.patch
@@ -1,3 +1,5 @@
+http://bugs.gentoo.org/206817
+
--- Makefile.am
+++ Makefile.am
@@ -37,7 +37,7 @@
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch
index 01545a7ce393..8cde1eb524f6 100644
--- a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch
@@ -1,6 +1,7 @@
-diff -urNad 3ddesktop-0.2.9/event.hpp /tmp/dpep.QstFBy/3ddesktop-0.2.9/event.hpp
---- 3ddesktop-0.2.9.orig/event.hpp 2004-12-06 03:57:32.000000000 +0100
-+++ 3ddesktop-0.2.9/event.hpp 2005-07-06 21:50:00.000000000 +0200
+http://bugs.gentoo.org/118458
+
+--- event.hpp
++++ event.hpp
@@ -74,7 +74,7 @@
list<Event *>::iterator k;
for (k = events.begin(); k != events.end(); ++k) {
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch
index cc30fda093cc..45970c19739e 100644
--- a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-missing-include.patch
@@ -1,6 +1,7 @@
-diff -u -r a/config.hpp b/config.hpp
---- a/config.hpp 2005-06-20 13:28:29.000000000 +0200
-+++ b/config.hpp 2008-12-17 19:40:05.000000000 +0100
+http://bugs.gentoo.org/228217
+
+--- config.hpp
++++ config.hpp
@@ -24,6 +24,7 @@
#include <stdio.h>