summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-01-15 12:24:35 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-01-15 12:24:35 +0000
commitab8a50f641aabcfe2a43f135f8b8cad94a482db0 (patch)
tree6c4a913ce3f6877f86019e0e54d686bc25436378 /x11-misc/3ddesktop
parentstable amd64 (diff)
downloadgentoo-2-ab8a50f641aabcfe2a43f135f8b8cad94a482db0.tar.gz
gentoo-2-ab8a50f641aabcfe2a43f135f8b8cad94a482db0.tar.bz2
gentoo-2-ab8a50f641aabcfe2a43f135f8b8cad94a482db0.zip
Fix compiling with gcc 4, see bug #118458.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-misc/3ddesktop')
-rw-r--r--x11-misc/3ddesktop/3ddesktop-0.2.9.ebuild11
-rw-r--r--x11-misc/3ddesktop/ChangeLog7
-rw-r--r--x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch13
3 files changed, 28 insertions, 3 deletions
diff --git a/x11-misc/3ddesktop/3ddesktop-0.2.9.ebuild b/x11-misc/3ddesktop/3ddesktop-0.2.9.ebuild
index 4686df1dc335..9fb28c570ab7 100644
--- a/x11-misc/3ddesktop/3ddesktop-0.2.9.ebuild
+++ b/x11-misc/3ddesktop/3ddesktop-0.2.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/3ddesktop-0.2.9.ebuild,v 1.6 2006/01/15 01:40:24 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/3ddesktop-0.2.9.ebuild,v 1.7 2006/01/15 12:24:35 nelchael Exp $
+
+inherit eutils
DESCRIPTION="OpenGL virtual desktop switching"
HOMEPAGE="http://desk3d.sourceforge.net/"
@@ -27,7 +29,12 @@ DEPEND="${RDEPEND}
x11-proto/xproto )
virtual/x11 )"
-src_install () {
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+}
+
+src_install() {
make DESTDIR="${D}" install || die
dodoc README AUTHORS TODO ChangeLog README.windowmanagers
}
diff --git a/x11-misc/3ddesktop/ChangeLog b/x11-misc/3ddesktop/ChangeLog
index 944c6cb4403b..d5389d8d0454 100644
--- a/x11-misc/3ddesktop/ChangeLog
+++ b/x11-misc/3ddesktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/3ddesktop
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/ChangeLog,v 1.32 2006/01/15 01:40:24 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/3ddesktop/ChangeLog,v 1.33 2006/01/15 12:24:35 nelchael Exp $
+
+ 15 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/3ddesktop-0.2.9-gcc4.patch, 3ddesktop-0.2.9.ebuild:
+ Fix compiling with gcc 4. Patch supplied by Simon Strandman
+ <simon.strandman@telia.com>, see bug #118458.
15 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> 3ddesktop-0.2.9.ebuild:
Stable on amd64, bug 118966.
diff --git a/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch
new file mode 100644
index 000000000000..95404894c23b
--- /dev/null
+++ b/x11-misc/3ddesktop/files/3ddesktop-0.2.9-gcc4.patch
@@ -0,0 +1,13 @@
+diff -urNad 3ddesktop-0.2.9/event.hpp /tmp/dpep.QstFBy/3ddesktop-0.2.9/event.hpp
+--- 3ddesktop-0.2.9/event.hpp 2004-12-06 03:57:32.000000000 +0100
++++ /tmp/dpep.QstFBy/3ddesktop-0.2.9/event.hpp 2005-07-06 21:50:00.000000000 +0200
+@@ -74,7 +74,7 @@
+ list<Event *>::iterator k;
+ for (k = events.begin(); k != events.end(); ++k) {
+ Event *e = *k;
+- printf(":: Event %d 0x%x\n", e->type, (unsigned int)(e->function));
++ printf(":: Event %d %p\n", e->type, e->function);
+ }
+ }
+
+