summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-16 19:41:37 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-16 19:41:37 +0000
commitffe1fee9c4fe0ead76f73eec2bbe53601bda258d (patch)
tree8736e692793a22d4ac789bdf5836a79048f09ff4 /x11-libs
parentDepend on bison since we used it to build #500660 by dwfreed. (diff)
downloadgentoo-2-ffe1fee9c4fe0ead76f73eec2bbe53601bda258d.tar.gz
gentoo-2-ffe1fee9c4fe0ead76f73eec2bbe53601bda258d.tar.bz2
gentoo-2-ffe1fee9c4fe0ead76f73eec2bbe53601bda258d.zip
fix building against recent libva, bug #501444.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva-vdpau-driver/ChangeLog7
-rw-r--r--x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch29
-rw-r--r--x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r1.ebuild3
3 files changed, 37 insertions, 2 deletions
diff --git a/x11-libs/libva-vdpau-driver/ChangeLog b/x11-libs/libva-vdpau-driver/ChangeLog
index fa8c416cbdc7..8ad33acbbc7c 100644
--- a/x11-libs/libva-vdpau-driver/ChangeLog
+++ b/x11-libs/libva-vdpau-driver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libva-vdpau-driver
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/ChangeLog,v 1.5 2014/02/01 15:24:44 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/ChangeLog,v 1.6 2014/02/16 19:41:37 chithanh Exp $
+
+ 16 Feb 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch,
+ libva-vdpau-driver-0.7.4-r1.ebuild:
+ fix building against recent libva, bug #501444.
*libva-vdpau-driver-0.7.4-r1 (01 Feb 2014)
diff --git a/x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch b/x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch
new file mode 100644
index 000000000000..74caee3483df
--- /dev/null
+++ b/x11-libs/libva-vdpau-driver/files/libva-vdpau-driver-0.7.4-VAEncH264VUIBufferType.patch
@@ -0,0 +1,29 @@
+>From fda3706eb74ba5ad874853969f3df3e372739c8d Mon Sep 17 00:00:00 2001
+From: "Xiang, Haihao" <haihao.xiang@intel.com>
+Date: Fri, 21 Jun 2013 12:55:30 +0800
+Subject: [PATCH] VAEncH264VUIBufferType and VAEncH264SEIBufferType are
+ dropped from VA API
+
+The driver doesn't use them indeed
+
+Signed-off-by: Xiang, Haihao <haihao.xiang@intel.com>
+---
+ src/vdpau_dump.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/vdpau_dump.c b/src/vdpau_dump.c
+index 899888b..610e7cd 100644
+--- a/src/vdpau_dump.c
++++ b/src/vdpau_dump.c
+@@ -59,8 +59,6 @@ const char *string_of_VABufferType(VABufferType type)
+ _(VAEncSequenceParameterBufferType);
+ _(VAEncPictureParameterBufferType);
+ _(VAEncSliceParameterBufferType);
+- _(VAEncH264VUIBufferType);
+- _(VAEncH264SEIBufferType);
+ #endif
+ #if VA_CHECK_VERSION(0,31,1)
+ _(VAQMatrixBufferType);
+--
+1.7.9.5
+
diff --git a/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r1.ebuild b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r1.ebuild
index 40901940513d..8e809fafded2 100644
--- a/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r1.ebuild
+++ b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r1.ebuild,v 1.1 2014/02/01 15:24:44 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/libva-vdpau-driver-0.7.4-r1.ebuild,v 1.2 2014/02/16 19:41:37 chithanh Exp $
EAPI=5
@@ -28,6 +28,7 @@ DOCS=( NEWS README AUTHORS )
src_prepare() {
epatch "${FILESDIR}/${P}-glext-missing-definition.patch"
+ epatch "${FILESDIR}/${P}-VAEncH264VUIBufferType.patch"
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
autotools-multilib_src_prepare
}