summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-04 01:00:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-04 01:00:01 +0000
commitfd80a0e55d52694fbadb4856ea30522a77fe281b (patch)
treec1731731bff93499bb82a152fc1cae65af82121a /x11-libs
parentversion bump (bug #63369) (Manifest recommit) (diff)
downloadgentoo-2-fd80a0e55d52694fbadb4856ea30522a77fe281b.tar.gz
gentoo-2-fd80a0e55d52694fbadb4856ea30522a77fe281b.tar.bz2
gentoo-2-fd80a0e55d52694fbadb4856ea30522a77fe281b.zip
USE=perl -> USE=pcre
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libast/libast-0.5-r2.ebuild18
-rw-r--r--x11-libs/libast/libast-0.6.ebuild12
2 files changed, 10 insertions, 20 deletions
diff --git a/x11-libs/libast/libast-0.5-r2.ebuild b/x11-libs/libast/libast-0.5-r2.ebuild
index 0f6fa283a43d..9acf36f0941e 100644
--- a/x11-libs/libast/libast-0.5-r2.ebuild
+++ b/x11-libs/libast/libast-0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r2.ebuild,v 1.6 2004/08/27 02:16:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r2.ebuild,v 1.7 2004/11/04 01:00:01 vapier Exp $
inherit 64-bit eutils
@@ -10,13 +10,13 @@ SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64"
-IUSE="X imlib mmx perl"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
+IUSE="X imlib mmx pcre"
DEPEND="virtual/x11
=media-libs/freetype-1*
- X? ( imlib? ( media-libs/imlib2 ) )
- perl? ( dev-libs/libpcre )"
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
src_unpack() {
unpack ${A}
@@ -25,13 +25,9 @@ src_unpack() {
}
src_compile() {
- local myconf
- use X && use imlib \
- && myconf="--with-imlib" \
- || myconf="--without-imlib"
econf \
- ${myconf} \
- `use_enable mmx` \
+ $(use_enable imlib) \
+ $(use_enable mmx) \
|| die
emake || die
}
diff --git a/x11-libs/libast/libast-0.6.ebuild b/x11-libs/libast/libast-0.6.ebuild
index 6adead17e3f8..0182e4ed7eb2 100644
--- a/x11-libs/libast/libast-0.6.ebuild
+++ b/x11-libs/libast/libast-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.6.ebuild,v 1.1 2004/11/04 00:51:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.6.ebuild,v 1.2 2004/11/04 01:00:01 vapier Exp $
inherit 64-bit eutils
@@ -11,18 +11,12 @@ SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-*"
-IUSE="imlib mmx perl"
+IUSE="imlib mmx pcre"
DEPEND="virtual/x11
=media-libs/freetype-1*
imlib? ( media-libs/imlib2 )
- perl? ( dev-libs/libpcre )"
-
-fsrc_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/libast-64bit.patch
-}
+ pcre? ( dev-libs/libpcre )"
src_compile() {
econf \