summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-10-30 17:49:15 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-10-30 17:49:15 +0000
commitde93f92edb7dead01c79132d5785a7feb191a96d (patch)
treeeabe4882537946d3a11186d52d7461894bd788b6 /x11-libs
parentStable on sparc (diff)
downloadgentoo-2-de93f92edb7dead01c79132d5785a7feb191a96d.tar.gz
gentoo-2-de93f92edb7dead01c79132d5785a7feb191a96d.tar.bz2
gentoo-2-de93f92edb7dead01c79132d5785a7feb191a96d.zip
Bump to 4.2.1, bringing in security fixes. Change dbus dep to dbus-core. Turn off tablet support by default unless the wacom input driver is set.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/qt-4.2.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11-libs/qt/qt-4.2.1.ebuild b/x11-libs/qt/qt-4.2.1.ebuild
index ef4f48973795..1bc87219cbc6 100644
--- a/x11-libs/qt/qt-4.2.1.ebuild
+++ b/x11-libs/qt/qt-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.1.ebuild,v 1.1 2006/10/30 17:23:13 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.1.ebuild,v 1.2 2006/10/30 17:49:15 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -14,7 +14,11 @@ S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
LICENSE="|| ( QPL-1.0 GPL-2 )"
SLOT="4"
KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="accessibility cups debug dbus doc examples firebird gif glib jpeg mng mysql nas nis odbc opengl pch png postgres sqlite xinerama zlib"
+
+IUSE_INPUT_DEVICES="input_devices_wacom"
+
+IUSE="accessibility cups debug dbus doc examples firebird gif glib jpeg mng mysql nas nis odbc opengl pch png postgres sqlite xinerama zlib ${IUSE_INPUT_DEVICES}"
+
# need glib and dbus
@@ -40,7 +44,8 @@ DEPEND="x11-libs/libXrandr
postgres? ( dev-db/libpq )
cups? ( net-print/cups )
zlib? ( sys-libs/zlib )
- glib? ( dev-libs/glib )"
+ glib? ( dev-libs/glib )
+ input_devices_wacom? ( x11-drivers/linuxwacom )"
pkg_setup() {
QTBASEDIR=/usr/$(get_libdir)/qt4
@@ -142,7 +147,9 @@ src_compile() {
use pch && myconf="${myconf} -pch"
- myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
+ use input_devices_wacom && myconf="${myconf} -tablet" || myconf="${myconf} -no-tablet"
+
+ myconf="${myconf} -xrender -xrandr -xkb -xshape -sm"
./configure -stl -verbose -largefile \
-platform ${PLATFORM} -xplatform ${PLATFORM} \