summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-18 19:16:44 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-18 19:16:44 +0000
commitd7709a0bc4ea50a66aaa65c464ed4aea6fe7f3f1 (patch)
tree3cae4a22607f35e7dbde64807de00735accfa357 /x11-libs
parentadd pkg_postinst notice about remerging kedlibs (diff)
downloadgentoo-2-d7709a0bc4ea50a66aaa65c464ed4aea6fe7f3f1.tar.gz
gentoo-2-d7709a0bc4ea50a66aaa65c464ed4aea6fe7f3f1.tar.bz2
gentoo-2-d7709a0bc4ea50a66aaa65c464ed4aea6fe7f3f1.zip
version bump #12380
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/ChangeLog17
-rw-r--r--x11-libs/wxGTK/files/digest-wxGTK-2.3.41
-rw-r--r--x11-libs/wxGTK/wxGTK-2.3.4.ebuild108
3 files changed, 118 insertions, 8 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 8a0b86e4bbcc..90eff8d504ae 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,15 +1,11 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.18 2002/12/18 15:00:47 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.19 2002/12/18 19:16:44 vapier Exp $
+*wxGTK-2.3.4 (18 Dec 2002)
-*wxGTK-2.2.9-r1 (18 Dec 2002)
-
- 18 Dec 2002; Seemant Kulleen <seemant@gentoo.org> wxGTK-2.2.9-r1.ebuild
- files/digest-wxGTK-2.2.9-r1 :
-
- This version is REQUIRED for audacity. If you are NOT the audacity or
- wxGTK maintainer, please do NOT touch these files.
+ 18 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage #12380 + re-enabling support for gtk2.
*wxGTK-2.3.3 (26 Oct 2002)
@@ -40,6 +36,11 @@
*wxGTK-2.2.9-r1 (09 Aug 2002)
+ 18 Dec 2002; Seemant Kulleen <seemant@gentoo.org> wxGTK-2.2.9-r1.ebuild
+ files/digest-wxGTK-2.2.9-r1 :
+ This version is REQUIRED for audacity. If you are NOT the audacity or
+ wxGTK maintainer, please do NOT touch these files.
+
22 Aug 2002; Nick Hadaway <raker@gentoo.org> wxGTK-2.2.9-r1.ebuild :
Changed to "e" tools for compiling.
Added some compile-time options suggested by Paul Thompson.
diff --git a/x11-libs/wxGTK/files/digest-wxGTK-2.3.4 b/x11-libs/wxGTK/files/digest-wxGTK-2.3.4
new file mode 100644
index 000000000000..1704912275ae
--- /dev/null
+++ b/x11-libs/wxGTK/files/digest-wxGTK-2.3.4
@@ -0,0 +1 @@
+MD5 239b08ce849ee7e7060f62dad00e3eaf wxGTK-2.3.4.tar.bz2 5108719
diff --git a/x11-libs/wxGTK/wxGTK-2.3.4.ebuild b/x11-libs/wxGTK/wxGTK-2.3.4.ebuild
new file mode 100644
index 000000000000..c9379d5c9066
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.3.4.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.3.4.ebuild,v 1.1 2002/12/18 19:16:44 vapier Exp $
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
+HOMEPAGE="http://www.wxwindows.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.3"
+KEYWORDS="x86 ppc sparc"
+IUSE="nls odbc jpeg png opengl motif gif tiff gtk gtk2 X"
+
+DEPEND="dev-libs/libunicode
+ media-libs/netpbm
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ sys-libs/zlib
+ odbc? ( dev-db/unixODBC )
+ opengl? ( virtual/opengl )
+ motif? ( x11-libs/openmotif )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ X? ( virtual/x11 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # xfree should not install these, remove until the fixed
+ # xfree is in main use.
+ rm -f /usr/X11R6/include/{zconf.h,zlib.h}
+}
+
+src_compile() {
+ local myconf
+
+ #Note: pcx image support enabled by default if found.
+ #Also, all wxWindows gui features are enabled by default. If you
+ #want to build a smaller library you can disable features by adding
+ #the appropriate flags to myconf (see INSTALL.txt).
+
+ #The build tools include a --with-freetype option, however it doesn't
+ #seem to be implemented in the source yet.
+
+ #confiure options that have corresponding USE variable.
+
+ use static \
+ && myconf="${myconf} --enable-static" \
+ || myconf="${myconf} --disable-static"
+
+ use nls \
+ && myconf="${myconf} --with-unicode" \
+ || myconf="${myconf} --without-unicode"
+
+ use gif \
+ && myconf="${myconf} --enable-gif" \
+ || myconf="${myconf} --disable-gif"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ # this doesnt work w/out zlib ... 2.3.4 was last ver checked
+# use zlib \
+# && myconf="${myconf} --with-zlib" \
+# || myconf="${myconf} --without-zlib"
+ myconf="${myconf} --with-zlib"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc" \
+ || myconf="${myconf} --without-odbc"
+
+ use opengl \
+ && myconf="${myconf} --with-opengl" \
+ || myconf="${myconf} --without-opengl"
+
+ use png \
+ && myconf="${myconf} --with-libpng --enable-png" \
+ || myconf="${myconf} --without-libpng --disable-png"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use X && myconf="${myconf} --with-x"
+
+ # here we specify our own preference of which toolkit to build ...
+ # but only gtk seems to work atm ...
+# if [ `use gtk` ] ; then
+ myconf="${myconf} --with-gtk"
+# elif [ `use X` ] ; then
+# myconf="${myconf} --with-x11"
+# elif [ `use motif` ] ; then
+# myconf="${myconf} --with-motif"
+# else
+# eerror "You must have either gtk, X, or motif in your USE variable"
+# die "could not specify toolkit"
+# fi
+ use gtk2 && myconf="${myconf} --enable-gtk2"
+
+ econf ${myconf}
+ make || die "make failed"
+}
+
+src_install() {
+ einstall
+ dodoc *.txt
+}