summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-23 20:15:32 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-23 20:15:32 +0000
commitc5947ddd0a9b566525045c3257333f77b3f46651 (patch)
tree9dda1587c94d8047aca5413ae114c3a9f8e99591 /x11-libs
parentRemoved libiptcdata mask from package use mask for bug #203059. (diff)
downloadgentoo-2-c5947ddd0a9b566525045c3257333f77b3f46651.tar.gz
gentoo-2-c5947ddd0a9b566525045c3257333f77b3f46651.tar.bz2
gentoo-2-c5947ddd0a9b566525045c3257333f77b3f46651.zip
Explicitly turn off sqlite2 support
(Portage version: 2.1.3.16)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild b/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild
index 7799bfbfde31..70b921a2b228 100644
--- a/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild,v 1.3 2007/12/22 23:06:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild,v 1.4 2007/12/23 20:15:32 caleb Exp $
inherit qt4-build
@@ -47,6 +47,9 @@ src_compile() {
use sqlite && myconf="${myconf} -plugin-sql-sqlite -system-sqlite" || myconf="${myconf} -no-sql-sqlite"
use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2"
+
if built_with_use ~x11-libs/qt-core-${PV} qt3support; then
myconf="${myconf} -qt3support"
else