summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-08-06 10:18:27 +0000
committerRémi Cardona <remi@gentoo.org>2009-08-06 10:18:27 +0000
commitc521b2ae3423118323d549ca48309ec66f915b39 (patch)
tree7115eb2b8d7605130dd4a15c5923b93683861907 /x11-libs
parentx11-libs/libXaw: bump to 1.0.6 (diff)
downloadgentoo-2-c521b2ae3423118323d549ca48309ec66f915b39.tar.gz
gentoo-2-c521b2ae3423118323d549ca48309ec66f915b39.tar.bz2
gentoo-2-c521b2ae3423118323d549ca48309ec66f915b39.zip
x11-libs/libxcb: bump to 1.4
(Portage version: 2.2_rc36/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxcb/ChangeLog7
-rw-r--r--x11-libs/libxcb/libxcb-1.4.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index 180ff8ef540d..fe4b1ae8c1af 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.31 2009/06/07 21:06:29 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.32 2009/08/06 10:18:27 remi Exp $
+
+*libxcb-1.4 (06 Aug 2009)
+
+ 06 Aug 2009; Rémi Cardona <remi@gentoo.org> +libxcb-1.4.ebuild:
+ bump to 1.4
*libxcb-1.3 (07 Jun 2009)
diff --git a/x11-libs/libxcb/libxcb-1.4.ebuild b/x11-libs/libxcb/libxcb-1.4.ebuild
new file mode 100644
index 000000000000..473270350bc6
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.4.ebuild,v 1.1 2009/08/06 10:18:27 remi Exp $
+
+EAPI="2"
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+LICENSE="X11"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux"
+
+RDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libpthread-stubs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-libs/libxslt
+ >=x11-proto/xcb-proto-1.5
+ >=dev-lang/python-2.5[xml]"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)
+ $(use_enable selinux xselinux)
+ --enable-xinput"
+}
+
+src_install() {
+ x-modular_src_install
+ dobin "${FILESDIR}"/xcb-rebuilder.sh || die
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "libxcb-1.2 removed libxcb-xlib.so. Run xcb-rebuilder.sh to rebuild"
+ ewarn "packages that broke. revdep-rebuild may also work."
+ ebeep 5
+ epause 5
+}