summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-02 16:54:11 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-02 16:54:11 +0000
commitc38fcdee957cb221f4fb9b011b3e0032c4278652 (patch)
treea51c27fec10675edfd84eca91acb5ae9c83a4a1a /x11-libs
parentRemoved from dev-libs (diff)
downloadgentoo-2-c38fcdee957cb221f4fb9b011b3e0032c4278652.tar.gz
gentoo-2-c38fcdee957cb221f4fb9b011b3e0032c4278652.tar.bz2
gentoo-2-c38fcdee957cb221f4fb9b011b3e0032c4278652.zip
Moved to x11-libs
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/files/digest-wxGTK-2.3.21
-rw-r--r--x11-libs/wxGTK/wxGTK-2.3.2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-libs/wxGTK/files/digest-wxGTK-2.3.2 b/x11-libs/wxGTK/files/digest-wxGTK-2.3.2
new file mode 100644
index 000000000000..ad6d0c5e4e25
--- /dev/null
+++ b/x11-libs/wxGTK/files/digest-wxGTK-2.3.2
@@ -0,0 +1 @@
+MD5 197e08767cde58ebc3996dd4b6fed905 wxGTK-2.3.2.tar.bz2 4710400
diff --git a/x11-libs/wxGTK/wxGTK-2.3.2.ebuild b/x11-libs/wxGTK/wxGTK-2.3.2.ebuild
new file mode 100644
index 000000000000..e50d1da013d9
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.3.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.3.2.ebuild,v 1.1 2002/01/02 16:54:11 verwilst Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+
+SRC_URI="http://prdownloads.sourceforge.net/wxwindows/${P}.tar.bz2"
+
+HOMEPAGE="http://www.wxwindows.org/"
+
+DEPEND=">=x11-libs/gtk+-1.2.3
+ dev-libs/libunicode
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ media-libs/netpbm
+ nls? ( sys-devel/gettext )
+ odbc? ( dev-db/unixODBC )
+ gif? ( media-libs/giflib )
+ opengl? ( virtual/opengl )"
+
+#Possible future dependancies
+# motif? ( x11-libs/openmotif )
+# ungif? ( media-libs/libungif )
+
+#RDEPEND=""
+
+src_compile() {
+
+
+ #cp configure.in configure.in.orig
+ #sed '1610i\ /usr/include/freetype2 \\' configure.in.orig > configure.in
+
+
+ local myconf
+ #--with-gtk enabled by default, if you want to build against motif,
+ #replace --with-gtk with --with-motif and --without-gtk. You will
+ #also need openmotif installed. Unfortunately, the package build tools
+ #only support installation of one currently.
+
+ myconf="--with-gtk"
+
+ #Build static library too, shared library is enabled by default.
+ #Enable useful config options that don't have USE flags
+ myconf="$myconf --enable-static --with-zlib --with-unicode"
+
+ #Note: png,jpeg,tiff,pnm, and pcx image support enabled by default if found.
+ #Also, all wxWindows gui features are enabled by default. If you
+ #want to build a smaller library you can disable features by adding
+ #the appropriate flags to myconf (see INSTALL.txt).
+
+ #The build tools include a --with-freetype option, however it doesn't
+ #seem to be implemented in the source yet.
+
+ #confiure options that have corresponding USE variable.
+
+ use odbc && myconf="$myconf --with-odbc" #disabled by default
+ use gif || myconf="$myconf --disable-gif" #enabled by default
+ use nls || myconf="$myconf --disable-intl" #enabled by default
+ use opengl && myconf="$myconf --with-opengl" #disabled by default
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf}|| die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ prefix=${D}/usr \
+ install || die
+
+ dodoc CHANGES-GTK.txt CHANGES.txt COPYING.LIB INSTALL.txt \
+ LICENSE.txt README-GTK.txt README.txt SYMBOLS.txt TODO.txt
+}
+