summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-14 22:01:55 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-14 22:01:55 +0000
commitbecf50828cb932401c262c7add827535d15de020 (patch)
treee24dfd55e75c79a57248aaa54963d0ef1541b479 /x11-libs
parentVersion bump (diff)
downloadgentoo-2-becf50828cb932401c262c7add827535d15de020.tar.gz
gentoo-2-becf50828cb932401c262c7add827535d15de020.tar.bz2
gentoo-2-becf50828cb932401c262c7add827535d15de020.zip
Remove orphaned symlinks in pkg_setup already, since pkg_preinst is only called after collision detection.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/openmotif-2.3.0-r1.ebuild68
1 files changed, 34 insertions, 34 deletions
diff --git a/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild b/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
index db1cd064845f..1f9d887ef1de 100644
--- a/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild,v 1.3 2008/02/14 17:41:41 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild,v 1.4 2008/02/14 22:01:55 ulm Exp $
inherit flag-o-matic multilib autotools
@@ -18,7 +18,7 @@ IUSE="doc examples jpeg png xft"
# since the slotting is finally gone now
RDEPEND="!x11-libs/motif-config
!x11-libs/lesstif
- !<x11-libs/openmotif-2.3.0
+ !<=x11-libs/openmotif-2.3.0
x11-libs/libXmu
x11-libs/libXaw
x11-libs/libXp
@@ -31,36 +31,7 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/motif"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # disable compilation of demo binaries
- sed -i -e 's/^[ \t]*demos//' Makefile.in
-}
-
-src_compile() {
- # get around some LANG problems in make (#15119)
- unset LANG
-
- # bug #80421
- filter-flags -ftracer
-
- # multilib includes don't work right in this package...
- has_multilib_profile && append-flags "-I$(get_ml_incdir)"
-
- # feel free to fix properly if you care
- append-flags -fno-strict-aliasing
-
- econf --with-x \
- $(use_enable xft) \
- $(use_enable jpeg) \
- $(use_enable png)
-
- emake -j1 || die "emake failed"
-}
-
-pkg_preinst() {
+pkg_setup() {
# clean up orphaned cruft left over by motif-config
local i count=0
local stalesyms="usr/bin/mwm \
@@ -85,9 +56,9 @@ pkg_preinst() {
done
cd "${ROOT}"usr/share/man
- find . -type l | while read i; do
+ for i in $(find . -type l); do
if [[ $(readlink "${i}") =~ -(openmo|less)tif- ]]; then
- ((count++))
+ (( count++ ))
rm -f "${i}"
fi
done
@@ -95,6 +66,35 @@ pkg_preinst() {
einfo "Cleaned up ${count} orphaned symlinks in ${ROOT}usr/share/man"
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable compilation of demo binaries
+ sed -i -e 's/^[ \t]*demos//' Makefile.in
+}
+
+src_compile() {
+ # get around some LANG problems in make (#15119)
+ unset LANG
+
+ # bug #80421
+ filter-flags -ftracer
+
+ # multilib includes don't work right in this package...
+ has_multilib_profile && append-flags "-I$(get_ml_incdir)"
+
+ # feel free to fix properly if you care
+ append-flags -fno-strict-aliasing
+
+ econf --with-x \
+ $(use_enable xft) \
+ $(use_enable jpeg) \
+ $(use_enable png)
+
+ emake -j1 || die "emake failed"
+}
+
src_install() {
emake -j1 DESTDIR="${D}" install || die "emake install failed"