summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-02-23 23:49:46 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-02-23 23:49:46 +0000
commitbe89f3f9c6fb82bd4cfa6db9d468cabd56e7a03a (patch)
tree2d1d343c5834a38353767bc7d99ef00e16aaf603 /x11-libs
parentunmask x11-misc/lightdm-1.1.3 (diff)
downloadgentoo-2-be89f3f9c6fb82bd4cfa6db9d468cabd56e7a03a.tar.gz
gentoo-2-be89f3f9c6fb82bd4cfa6db9d468cabd56e7a03a.tar.bz2
gentoo-2-be89f3f9c6fb82bd4cfa6db9d468cabd56e7a03a.zip
Allow using libiodbc instead of unixODBC (bug #295342 by Rafał Mużyło), remove useless iconv USE flag, delete obsolete sed, don't extract more directories than necessary, cleanup src_configure.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-sql/ChangeLog10
-rw-r--r--x11-libs/qt-sql/qt-sql-4.8.0-r1.ebuild67
-rw-r--r--x11-libs/qt-sql/qt-sql-4.8.0.ebuild71
3 files changed, 76 insertions, 72 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index c07075f31a8b..5656c5a8b042 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.119 2012/01/29 23:33:50 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.120 2012/02/23 23:49:46 pesa Exp $
+
+*qt-sql-4.8.0-r1 (23 Feb 2012)
+
+ 23 Feb 2012; Davide Pesavento <pesa@gentoo.org> +qt-sql-4.8.0-r1.ebuild,
+ -qt-sql-4.8.0.ebuild:
+ Allow using libiodbc instead of unixODBC (bug #295342 by Rafał Mużyło), remove
+ useless iconv USE flag, delete obsolete sed, don't extract more directories
+ than necessary, cleanup src_configure.
29 Jan 2012; Joseph Jezak <josejx@gentoo.org> qt-sql-4.7.4.ebuild:
Marked ppc ppc64 stable for bug #390963.
diff --git a/x11-libs/qt-sql/qt-sql-4.8.0-r1.ebuild b/x11-libs/qt-sql/qt-sql-4.8.0-r1.ebuild
new file mode 100644
index 000000000000..d829f8e66eac
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.8.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.8.0-r1.ebuild,v 1.1 2012/02/23 23:49:46 pesa Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="firebird freetds mysql odbc postgres qt3support +sqlite"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,c++0x=,qpa=,debug=,qt3support=]
+ firebird? ( dev-db/firebird )
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/mysql )
+ odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/sql
+ src/plugins/sqldrivers"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt
+ include/QtCore
+ include/QtSql
+ src/src.pro
+ src/corelib
+ src/plugins
+ src/tools/tools.pro"
+
+ if ! { use firebird || use freetds || use mysql || use odbc || use postgres || use sqlite; }; then
+ ewarn "You need to enable at least one SQL driver. Enable at least one"
+ ewarn "of these USE flags: \"firebird freetds mysql odbc postgres sqlite\"."
+ die "Enable at least one SQL driver."
+ fi
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ $(qt_use firebird sql-ibase plugin)
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql")
+ $(qt_use odbc sql-odbc plugin) $(use odbc && echo "-I${EPREFIX}/usr/include/iodbc")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo -system-sqlite)
+ -no-sql-db2
+ -no-sql-oci
+ -no-sql-sqlite2
+ -no-sql-symsql
+ $(qt_use qt3support)
+ -no-accessibility -no-xmlpatterns -no-multimedia -no-audio-backend -no-phonon
+ -no-phonon-backend -no-svg -no-webkit -no-script -no-scripttools -no-declarative
+ -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg -no-openssl
+ -no-cups -no-dbus -no-gtkstyle -no-nas-sound -no-opengl
+ -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes
+ -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb
+ -no-glib"
+
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-sql/qt-sql-4.8.0.ebuild b/x11-libs/qt-sql/qt-sql-4.8.0.ebuild
deleted file mode 100644
index da95ab0a0bb8..000000000000
--- a/x11-libs/qt-sql/qt-sql-4.8.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.8.0.ebuild,v 1.1 2012/01/29 17:08:13 wired Exp $
-
-EAPI="3"
-inherit qt4-build
-
-DESCRIPTION="The SQL module for the Qt toolkit"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="firebird freetds iconv mysql odbc postgres qt3support +sqlite"
-
-DEPEND="~x11-libs/qt-core-${PV}[aqua=,c++0x=,qpa=,debug=,qt3support=]
- firebird? ( dev-db/firebird )
- freetds? ( dev-db/freetds )
- mysql? ( virtual/mysql )
- odbc? ( dev-db/unixODBC )
- postgres? ( dev-db/postgresql-base )
- sqlite? ( dev-db/sqlite:3 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- include/Qt/
- include/QtCore/
- include/QtSql/
- include/QtScript/
- src/src.pro
- src/corelib/
- src/plugins
- src/3rdparty
- src/tools"
-
- if ! ( use firebird || use freetds || use mysql || use odbc || use postgres || use sqlite );
- then
- ewarn "You need to enable at least one SQL driver. Enable at least"
- ewarn "one of these USE flags: \"firebird freetds mysql odbc postgres sqlite tds\"."
- die "Enable at least one SQL driver."
- fi
-
- qt4-build_pkg_setup
-}
-
-src_prepare() {
- qt4-build_src_prepare
-
- sed -e '/pg_config --libs/d' -i "${S}"/configure \
- || die "sed to fix postgresql usage in ./configure failed"
-}
-
-src_configure() {
- # Don't support sqlite2 anymore
- myconf="${myconf} -no-sql-sqlite2
- $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql ")
- $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql ")
- $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
- $(qt_use odbc sql-odbc plugin)
- $(qt_use freetds sql-tds plugin)
- $(qt_use firebird sql-ibase plugin)
- $(qt_use qt3support)"
-
- myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
- -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
- -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
- -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
-
- qt4-build_src_configure
-}