summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-04 10:23:35 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-04 10:23:35 +0000
commitb171fae29fa0abdd7a3562f5e936cef8830c5681 (patch)
tree84fd25b216b3c3bb70db7e35251236e9d7a33dcd /x11-libs
parentversion bump (diff)
downloadgentoo-2-b171fae29fa0abdd7a3562f5e936cef8830c5681.tar.gz
gentoo-2-b171fae29fa0abdd7a3562f5e936cef8830c5681.tar.bz2
gentoo-2-b171fae29fa0abdd7a3562f5e936cef8830c5681.zip
version bump
(Portage version: 2.2_rc43/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-opengl/ChangeLog7
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.5.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index 49c0a4667ddc..dd4d38ff3c78 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.37 2009/08/30 00:48:21 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.38 2009/10/04 10:23:35 wired Exp $
+
+*qt-opengl-4.5.3 (04 Oct 2009)
+
+ 04 Oct 2009; Alex Alexander <wired@gentoo.org> +qt-opengl-4.5.3.ebuild:
+ version bump
*qt-opengl-4.5.2-r1 (30 Aug 2009)
diff --git a/x11-libs/qt-opengl/qt-opengl-4.5.3.ebuild b/x11-libs/qt-opengl/qt-opengl-4.5.3.ebuild
new file mode 100644
index 000000000000..1cc15f5c605c
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.5.3.ebuild,v 1.1 2009/10/04 10:23:35 wired Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[debug=,qt3support=]
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/opengl
+src/plugins/graphicssystems/opengl"
+
+QT4_EXTRACT_DIRECTORIES="
+include/QtCore
+include/QtGui
+include/QtOpenGL
+src/corelib
+src/gui
+src/opengl
+src/plugins
+src/3rdparty"
+
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}