summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-28 18:10:49 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-28 18:10:49 +0000
commitb15fa911571cc56c7940c79d5e54675b174cda2d (patch)
treeb620d05a6cd816b83cc2043c5f67b0786fc62b12 /x11-libs
parentVersion bump. (diff)
downloadgentoo-2-b15fa911571cc56c7940c79d5e54675b174cda2d.tar.gz
gentoo-2-b15fa911571cc56c7940c79d5e54675b174cda2d.tar.bz2
gentoo-2-b15fa911571cc56c7940c79d5e54675b174cda2d.zip
Add patch to fix building against xcb-proto-1.9, bug #490884. Remove old.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xpyb/ChangeLog10
-rw-r--r--x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch11
-rw-r--r--x11-libs/xpyb/xpyb-1.2-r1.ebuild30
-rw-r--r--x11-libs/xpyb/xpyb-1.3.1-r1.ebuild31
-rw-r--r--x11-libs/xpyb/xpyb-1.3.1-r2.ebuild3
-rw-r--r--x11-libs/xpyb/xpyb-1.3.1-r3.ebuild49
-rw-r--r--x11-libs/xpyb/xpyb-1.3.1.ebuild32
7 files changed, 71 insertions, 95 deletions
diff --git a/x11-libs/xpyb/ChangeLog b/x11-libs/xpyb/ChangeLog
index 16aef67bb53f..b9235d60bf2e 100644
--- a/x11-libs/xpyb/ChangeLog
+++ b/x11-libs/xpyb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/xpyb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/ChangeLog,v 1.50 2013/10/08 05:08:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/ChangeLog,v 1.51 2013/11/28 18:10:48 chithanh Exp $
+
+*xpyb-1.3.1-r3 (28 Nov 2013)
+
+ 28 Nov 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xpyb-1.3.1-xcbproto-1.9.patch, +xpyb-1.3.1-r3.ebuild,
+ -xpyb-1.2-r1.ebuild, -xpyb-1.3.1-r1.ebuild, -xpyb-1.3.1.ebuild,
+ xpyb-1.3.1-r2.ebuild:
+ Add patch to fix building against xcb-proto-1.9, bug #490884. Remove old.
08 Oct 2013; Agostino Sarubbo <ago@gentoo.org> xpyb-1.3.1-r2.ebuild:
Stable for x86, wrt bug #475480
diff --git a/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch b/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch
new file mode 100644
index 000000000000..1196741b3cbe
--- /dev/null
+++ b/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch
@@ -0,0 +1,11 @@
+diff -ruN xpyb-1.3.1_ORIG/src/py_client.py xpyb-1.3.1/src/py_client.py
+--- xpyb-1.3.1_ORIG/src/py_client.py 2013-11-17 12:57:05.157530931 +0100
++++ xpyb-1.3.1/src/py_client.py 2013-11-17 12:57:52.221530100 +0100
+@@ -19,6 +19,7 @@
+ 'INT8': 'b', 'int8_t': 'b',
+ 'INT16': 'h', 'int16_t': 'h',
+ 'INT32': 'i', 'int32_t': 'i',
++ 'INT64': 'i', 'int64_t': 'i',
+ 'BYTE': 'B',
+ 'BOOL': 'B',
+ 'char': 'b',
diff --git a/x11-libs/xpyb/xpyb-1.2-r1.ebuild b/x11-libs/xpyb/xpyb-1.2-r1.ebuild
deleted file mode 100644
index 0914666523be..000000000000
--- a/x11-libs/xpyb/xpyb-1.2-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.2-r1.ebuild,v 1.5 2013/05/11 07:26:11 patrick Exp $
-
-inherit x-modular autotools
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
-SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
-DESCRIPTION="XCB-based Python bindings for the X Window System"
-HOMEPAGE="http://xcb.freedesktop.org/ http://pypi.python.org/pypi/xpyb"
-
-KEYWORDS="amd64 x86"
-IUSE="selinux"
-
-RDEPEND=">=x11-libs/libxcb-1.1
- >=dev-lang/python-2.5"
-DEPEND="${RDEPEND}
- >=x11-proto/xcb-proto-1.2"
-
-DOCS="NEWS README"
-
-pkg_setup() {
- CONFIGURE_OPTIONS="$(use_enable selinux xselinux)"
-}
-
-src_unpack() {
- x-modular_src_unpack
-
- eautoreconf
-}
diff --git a/x11-libs/xpyb/xpyb-1.3.1-r1.ebuild b/x11-libs/xpyb/xpyb-1.3.1-r1.ebuild
deleted file mode 100644
index ce231283acf9..000000000000
--- a/x11-libs/xpyb/xpyb-1.3.1-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.3.1-r1.ebuild,v 1.14 2013/09/05 19:44:47 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit python-single-r1 xorg-2
-
-#EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
-SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
-DESCRIPTION="XCB-based Python bindings for the X Window System"
-HOMEPAGE="http://xcb.freedesktop.org/"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="selinux"
-
-RDEPEND=">=x11-libs/libxcb-1.7
- >=x11-proto/xcb-proto-1.7.1[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-DOCS=( NEWS README )
-
-pkg_setup() {
- python-single-r1_pkg_setup
- xorg-2_pkg_setup
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable selinux xselinux)
- )
-}
diff --git a/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild b/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild
index b46624393f31..c2961d71e537 100644
--- a/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild
+++ b/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild,v 1.11 2013/10/08 05:08:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild,v 1.12 2013/11/28 18:10:48 chithanh Exp $
EAPI=5
@@ -19,6 +19,7 @@ IUSE="selinux"
RDEPEND=">=x11-libs/libxcb-1.7
>=x11-proto/xcb-proto-1.7.1[${PYTHON_USEDEP}]
+ <x11-proto/xcb-proto-1.9
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
diff --git a/x11-libs/xpyb/xpyb-1.3.1-r3.ebuild b/x11-libs/xpyb/xpyb-1.3.1-r3.ebuild
new file mode 100644
index 000000000000..a196eb993f65
--- /dev/null
+++ b/x11-libs/xpyb/xpyb-1.3.1-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.3.1-r3.ebuild,v 1.1 2013/11/28 18:10:48 chithanh Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+AUTOTOOLS_AUTORECONF=1
+
+inherit flag-o-matic xorg-2 python-r1
+
+#EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+DESCRIPTION="XCB-based Python bindings for the X Window System"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="selinux"
+
+RDEPEND=">=x11-libs/libxcb-1.7
+ >=x11-proto/xcb-proto-1.7.1[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-python.patch
+ "${FILESDIR}"/${PN}-1.3.1-xcbproto-1.9.patch
+)
+DOCS=( NEWS README )
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable selinux)
+ )
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+ python_foreach_impl xorg-2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl xorg-2_src_compile
+}
+
+src_install() {
+ python_foreach_impl xorg-2_src_install
+}
diff --git a/x11-libs/xpyb/xpyb-1.3.1.ebuild b/x11-libs/xpyb/xpyb-1.3.1.ebuild
deleted file mode 100644
index bdd5e21d0722..000000000000
--- a/x11-libs/xpyb/xpyb-1.3.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpyb/xpyb-1.3.1.ebuild,v 1.12 2013/03/10 14:23:39 blueness Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-inherit python xorg-2
-
-#EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
-SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
-DESCRIPTION="XCB-based Python bindings for the X Window System"
-HOMEPAGE="http://xcb.freedesktop.org/"
-
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="selinux"
-
-RDEPEND=">=x11-libs/libxcb-1.7
- >=x11-proto/xcb-proto-1.7.1"
-DEPEND="${RDEPEND}"
-
-DOCS=( NEWS README )
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-
- xorg-2_pkg_setup
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable selinux xselinux)
- )
-}